# Kibana won't run with Shield LicenseExpiredException

**URL:** https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681
**Category:** Kibana
**Created:** [October 6, 2015, 9:17am UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681 "2015-10-06T09:17:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![rsjavier](https://avatars.discourse-cdn.com/v4/letter/r/9e8a1a/32.png) [@rsjavier](https://discuss.elastic.co/u/rsjavier)
#### Post date: [October 6, 2015, 9:17am UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681/1 "2015-10-06T09:17:25Z")

</div>

I have my Kibana, Elastic and Shield running for quite sometime. The system is working properly even the Shield expired. But when I try to restart the ElasticSearch and Kibana, the Kibana then will run but gives me fatal error regarding Shield License and exit.

[root@xxxx kibana-4.0.1-linux-x64]# ./bin/kibana  
{"@timestamp":"2015-10-06T08:47:12.126Z","level":"error","message":"LicenseExpiredException[license expired for feature [shield]]","node\_env":"production","error":{"message":"LicenseExpiredException[license expired for feature [shield]]","name":"Error","stack":"Error: LicenseExpiredException[license expired for feature [shield]]\n at respond (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/transport.js:235:15)\n at checkRespForFailure (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/transport.js:203:7)\n at HttpConnector. (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/connectors/http.js:156:7)\n at IncomingMessage.bound (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/node\_modules/lodash-node/modern/internals/baseBind.js:56:17)\n at IncomingMessage.emit (events.js:117:20)\n at \_stream\_readable.js:944:16\n at process.\_tickCallback (node.js:442:13)\n"}}  
{"@timestamp":"2015-10-06T08:47:12.128Z","level":"fatal","message":"LicenseExpiredException[license expired for feature [shield]]","node\_env":"production","error":{"message":"LicenseExpiredException[license expired for feature [shield]]","name":"Error","stack":"Error: LicenseExpiredException[license expired for feature [shield]]\n at respond (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/transport.js:235:15)\n at checkRespForFailure (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/transport.js:203:7)\n at HttpConnector. (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/src/lib/connectors/http.js:156:7)\n at IncomingMessage.bound (/root/kibana-4.0.1-linux-x64/src/node\_modules/elasticsearch/node\_modules/lodash-node/modern/internals/baseBind.js:56:17)\n at IncomingMessage.emit (events.js:117:20)\n at \_stream\_readable.js:944:16\n at process.\_tickCallback (node.js:442:13)\n"}}

From what I understand only the cluster health and monitoring will not be available when the Shield expired. How can I make the system run again? Thanks!

---

<div class="post-metadata">

### Author: ![tbragin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbragin/32/45166_2.png) [@tbragin](https://discuss.elastic.co/u/tbragin)
#### Post date: [October 6, 2015, 4:23pm UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681/2 "2015-10-06T16:23:01Z")

</div>

Kibana requires Elasticsearch health and monitoring permissions to make sure Elasticsearch backend is available. So you'll need to get a valid license to use Kibana with Shield.

---

<div class="post-metadata">

### Author: ![rsjavier](https://avatars.discourse-cdn.com/v4/letter/r/9e8a1a/32.png) [@rsjavier](https://discuss.elastic.co/u/rsjavier)
#### Post date: [October 12, 2015, 7:22am UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681/3 "2015-10-12T07:22:16Z")

</div>

Thanks!

---

<div class="post-metadata">

### Author: ![brandber](https://avatars.discourse-cdn.com/v4/letter/b/278dde/32.png) [@brandber](https://discuss.elastic.co/u/brandber)
#### Post date: [April 18, 2016, 4:37pm UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681/4 "2016-04-18T16:37:14Z")

</div>

I had the same question. When I thought about evaluating Shield, the docs gave me the impression that some features that were non-critical to me would no longer function, but I could still use Kibana. This is not the case. I would just suggest clearly setting expectations on what will stop working (i.e. Kibana) so it is not a surprise.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:55pm UTC](https://discuss.elastic.co/t/kibana-wont-run-with-shield-licenseexpiredexception/31681/5 "2017-07-06T13:55:49Z")

</div>


