# Kibana won't start after upgrade to 7.8.0

**URL:** https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819
**Category:** Kibana
**Created:** [June 19, 2020, 2:34pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819 "2020-06-19T14:34:04Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 19, 2020, 2:34pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/1 "2020-06-19T14:34:04Z")

</div>

I apply this to three node cluster  
all of them are master/data/kibana  
two of them starts up kibana without any problem

one does not. it do not even puts any log on log file or on screen

systemctl status kibana  
● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)  
Active: activating (auto-restart) (Result: exit-code) since Fri 2020-06-19 09:24:45 CDT; 1s ago  
Process: 31345 ExecStart=/usr/share/kibana/bin/kibana (code=exited, status=1/FAILURE)  
Main PID: 31345 (code=exited, status=1/FAILURE)

Jun 19 09:24:45 elkdev01 systemd[1]: Unit kibana.service entered failed state.  
Jun 19 09:24:45 elkdev01 systemd[1]: kibana.service failed.

---

<div class="post-metadata">

### Author: ![abrx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abrx/32/43881_2.png) [@abrx](https://discuss.elastic.co/u/abrx)
#### Post date: [June 19, 2020, 2:59pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/2 "2020-06-19T14:59:08Z")

</div>

Are kibana folders with the right user ? With space left on filesystem ?  
Is kibana port free ?

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 19, 2020, 3:01pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/3 "2020-06-19T15:01:53Z")

</div>

> [@abrx](#):
>
> ight user ? With space left on filesystem ?

enough space,  
all folder with proper permission as other system as I double check.  
netstat show port is not being used 5601

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 19, 2020, 3:17pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/4 "2020-06-19T15:17:58Z")

</div>

I even rebooted system. but same thing

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 19, 2020, 3:29pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/5 "2020-06-19T15:29:27Z")

</div>

is it something to do with user  
kibana\_system as I read in release note that user kibana is no longer used

I am using user kibana in my config file. but how come two system are still working? this is most definitly something to do with 7.8 version

elasticsearch.username: "kibana"  
elasticsearch.password: "pass"

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 20, 2020, 1:07pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/6 "2020-06-20T13:07:39Z")

</div>

anyone having issue after upgrade?

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 20, 2020, 1:15pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/7 "2020-06-20T13:15:12Z")

</div>

I have install kibana as root and running as root

```
journalctl -fu kibana.service
-- Logs begin at Fri 2020-06-19 10:14:56 CDT. --
Jun 20 08:11:40 elkdev01 kibana[12793]: at Module._compile (/usr/share/kibana/node_modules/pirates/lib/index.js:99:24)
Jun 20 08:11:40 elkdev01 kibana[12793]: at Module._extensions..js (internal/modules/cjs/loader.js:789:10)
Jun 20 08:11:40 elkdev01 systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Jun 20 08:11:40 elkdev01 systemd[1]: Unit kibana.service entered failed state.
Jun 20 08:11:40 elkdev01 systemd[1]: kibana.service failed.
Jun 20 08:11:43 elkdev01 systemd[1]: kibana.service holdoff time over, scheduling restart.
Jun 20 08:11:43 elkdev01 systemd[1]: start request repeated too quickly for kibana.service
Jun 20 08:11:43 elkdev01 systemd[1]: Failed to start Kibana.
Jun 20 08:11:43 elkdev01 systemd[1]: Unit kibana.service entered failed state.
Jun 20 08:11:43 elkdev01 systemd[1]: kibana.service failed.
```

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 22, 2020, 3:24pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/8 "2020-06-22T15:24:57Z")

</div>

I have even reinstall kibana.  
first remove kibana package, remove all dir's and reinstall.

still won't start and no error message on log at all.

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 23, 2020, 2:00pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/9 "2020-06-23T14:00:12Z")

</div>

fixed.  
something went wrong with uid/gid I guess.

remove rpm first  
than created manual uid/gid same as my other two node on cluster.  
install rpm again  
copy back same config that I had it before

restarted and it is working.

do not know what went wrong on installation but something did which cause this problem.

This has the fixed.

[https://discuss.elastic.co/t/kibana-upgrade-to-7-8-fatal-cli-error-error-enoent-no-such-file-or-directory/239885/6](https://discuss.elastic.co/t/kibana-upgrade-to-7-8-fatal-cli-error-error-enoent-no-such-file-or-directory/239885/6)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 21, 2020, 2:00pm UTC](https://discuss.elastic.co/t/kibana-wont-start-after-upgrade-to-7-8-0/237819/10 "2020-07-21T14:00:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
