# Kibanaclient - Error when executing Kibana client request -nagios

**URL:** <https://discuss.elastic.co/t/kibanaclient-error-when-executing-kibana-client-request-nagios/206577>\
**Category:** Logstash\
**Created:** [November 5, 2019, 9:48am UTC](https://discuss.elastic.co/t/kibanaclient-error-when-executing-kibana-client-request-nagios/206577 "2019-11-05T09:48:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![anusree\_arun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anusree_arun/32/55826_2.png) [@anusree\_arun](https://discuss.elastic.co/u/anusree_arun)\
**Post date:** [November 5, 2019, 9:48am UTC](https://discuss.elastic.co/t/kibanaclient-error-when-executing-kibana-client-request-nagios/206577/1 "2019-11-05T09:48:06Z")

</div>

i am now using nagios module in my logstash .  
when i run the command  
/usr/share/logstash/bin/logstash --modules nagios --setup ---i got an error like as below

Thread.exclusive is deprecated, use Thread::Mutex  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
[WARN] 2019-11-05 15:21:08.247 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[INFO] 2019-11-05 15:21:08.261 [LogStash::Runner] runner - Starting Logstash {"logstash.version"=\>"7.4.0"}  
[INFO] 2019-11-05 15:21:09.062 [Agent thread] modulescommon - Setting up the nagios module  
[ERROR] 2019-11-05 15:21:09.786 [Agent thread] kibanaclient - Error when executing Kibana client request {:error=\>#\<Manticore::SocketException: Connection refused (Connection refused)\>}  
[ERROR] 2019-11-05 15:21:09.902 [Agent thread] kibanaclient - Error when executing Kibana client request {:error=\>#\<Manticore::SocketException: Connection refused (Connection refused)\>}  
[ERROR] 2019-11-05 15:21:10.098 [Agent thread] sourceloader - Could not fetch all the sources {:exception=\>LogStash::ConfigLoadingError, :message=\>"Failed to import module configurations to Elasticsearch and/or Kibana. Module: nagios has Elasticsearch hosts: ["localhost:9200"] and Kibana hosts: ["localhost:5601"]", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/config/modules\_common.rb:108:in `block in pipeline_configs'", "org/jruby/RubyArray.java:1800:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/config/modules\_common.rb:54:in `pipeline_configs'", "/usr/share/logstash/logstash-core/lib/logstash/config/source/modules.rb:14:in `pipeline\_configs'", "/usr/share/logstash/logstash-core/lib/logstash/config/source\_loader.rb:61:in `block in fetch'", "org/jruby/RubyArray.java:2579:in `collect'", "/usr/share/logstash/logstash-core/lib/logstash/config/source\_loader.rb:60:in `fetch'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:149:in `converge\_state\_and\_update'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:97:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:368:in `block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/stud-0.0.23/lib/stud/task.rb:24:in `block in initialize'"]} [ERROR] 2019-11-05 15:21:10.106 [Agent thread] agent - An exception happened when converging configuration {:exception=>RuntimeError, :message=>"Could not fetch the configuration, message: Failed to import module configurations to Elasticsearch and/or Kibana. Module: nagios has Elasticsearch hosts: [\"localhost:9200\"] and Kibana hosts: [\"localhost:5601\"]", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/agent.rb:156:in `converge\_state\_and\_update'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:97:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:368:in `block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/stud-0.0.23/lib/stud/task.rb:24:in `block in initialize'"]}  
[INFO] 2019-11-05 15:21:10.424 [LogStash::Runner] runner - Logstash shut down.

please help to sort it out

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 3, 2019, 9:48am UTC](https://discuss.elastic.co/t/kibanaclient-error-when-executing-kibana-client-request-nagios/206577/2 "2019-12-03T09:48:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
