# Kibanna is very slow and UI stcuk

**URL:** https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394
**Category:** Kibana
**Created:** [November 5, 2018, 12:19pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394 "2018-11-05T12:19:16Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 5, 2018, 12:19pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/1 "2018-11-05T12:19:16Z")

</div>

Hi Team,  
My kibana UI is responding very slow and some time stuck while searching . its setup on Dockers containers.  
1 - Container - ElasticSearch  
2 - Container LogStach  
3 - Container Kibana

I check the logs of Elasticserach docker container on my Host server and i fould the below warnings.

is that can be the issue of slowness and stuck my Kibana

# docker logs dockerelk\_elasticsearch\_1

[2018-10-30T10:25:54,480][WARN][o.e.b.BootstrapChecks] [vHE4RKF] max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]

[2018-10-30T10:48:21,871][WARN][o.e.d.s.f.s.DocValueFieldsFetchSubPhase] Doc-value field [@timestamp] is not using a format. The output will change in 7.0 when doc value fields get formatted based on mappings by default. It is recommended to pass [format=use\_field\_mapping] with the doc value field in order to opt in for the future behaviour and ease the migration to 7.0.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [November 5, 2018, 12:43pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/2 "2018-11-05T12:43:54Z")

</div>

How much data do you have in your cluster? How many indices and shards? What is the specification of the host where the stack is running? What kind of storage are you using?

---

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 5, 2018, 12:58pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/3 "2018-11-05T12:58:56Z")

</div>

@Christian_Dahlqvist, PFA!

Please find below my Host details on which container is setup for ELK (single node server).

OS Ubuntu 18.xx LTE  
EC2 Instance Tyep: t2.medium  
VCPU: 2  
RAM: 4 GB  
HDD: 150 GB

1 - How can i check the size of data on my ELk server ?  
2 - How can I check how many indices and shards ?

Thanks

 ![Fatel%20Error%20Kibana%20UI%20%202018-11-05%2016-46-08](https://us1.discourse-cdn.com/elastic/original/3X/a/5/a5e79a3e9bd924388b3c5cf82df70c3eae863e24.png)

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [November 5, 2018, 1:01pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/4 "2018-11-05T13:01:42Z")

</div>

> [@shahid](#):
>
> t2.medium

t2 instance types have very limited burstable CPU, so are not ideal. I would recommend switching to a small m4/m5 instance types instead, which has constant CPU and is likely to give much better performance.

---

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 5, 2018, 1:03pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/5 "2018-11-05T13:03:46Z")

</div>

so the error on the screen short is due to the resource bottleneck ?  
because while setup the beats on client site i am getting this error of time as well.

2018-11-05T11:42:57.681Z ERROR instance/beat.go:743 Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/kibana: Failed to import dashboard: Failed to load directory /usr/share/metricbeat/kibana/6/dashboard:  
error loading /usr/share/metricbeat/kibana/6/dashboard/Metricbeat-apache-overview.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Request Timeout after 30000ms"}

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [November 5, 2018, 1:10pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/6 "2018-11-05T13:10:14Z")

</div>

I have seen users having problems with t2 instances when just running Elasticsearch on them. You are trying to also run Kibana and Logstash, which can be CPU intensive, so I am not surprised you are seeing timeouts. Check any monitoring data you have and see how CPU usage/credits look like over time, and I suspect you will see what the bottleneck is.

---

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 5, 2018, 1:21pm UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/7 "2018-11-05T13:21:52Z")

</div>

@Christian_Dahlqvist.  
Thanks for the immediate response.  
here is exact stats i got from the server.

buntu@ip-xx.x.x.xx:~$ curl -XGET 'ElasticServerIP:9200/\_cat/allocation?v&pretty'

shards disk.indices disk.used disk.avail disk.total disk.percent host ip node  
42 4.6gb 11.5gb 85.2gb 96.8gb 11 172.x.x.xx vHE4dbKF  
41 UNASSIGNED

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [November 8, 2018, 8:26am UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/8 "2018-11-08T08:26:59Z")

</div>

Did you try another instance type? Did it work better?

---

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 8, 2018, 8:32am UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/9 "2018-11-08T08:32:40Z")

</div>

@Christian_Dahlqvist no i did,nt try other type yet. its lilt better now . after doing some memory tweaking on Host and container on ES.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 6, 2018, 8:32am UTC](https://discuss.elastic.co/t/kibanna-is-very-slow-and-ui-stcuk/155394/10 "2018-12-06T08:32:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
