# Kubernete integration with Fleet

**URL:** <https://discuss.elastic.co/t/kubernete-integration-with-fleet/307712>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Tags:** docker, fleet, elastic-agent\
**Created:** [June 21, 2022, 5:14am UTC](https://discuss.elastic.co/t/kubernete-integration-with-fleet/307712 "2022-06-21T05:14:15Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ehsan\_Orve](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ehsan_orve/32/107317_2.png) [@Ehsan\_Orve](https://discuss.elastic.co/u/Ehsan_Orve)\
**Post date:** [June 21, 2022, 5:14am UTC](https://discuss.elastic.co/t/kubernete-integration-with-fleet/307712/1 "2022-06-21T05:14:15Z")

</div>

Hi  
I have started working with elastic\_agent for Kubernetes. I have deployed elastic\_agent pod with DaemonSet in kuber cluster and then register them successfully in Fleet by policy. But filebeat cant read the container logs. In kibana I receive this error rapidly:

`[elastic_agent.filebeat][error] Error extracting container id - source value does not contain matcher's logs_path '/var/lib/docker/containers/'.`

I know this issue has been resolved for filebeat installation in standalone mode, but in agent mode I can't find a solution to resolve it.  
every agent are healthy.

---

<div class="post-metadata">

**Author:** ![michael.morello](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michael.morello/32/47448_2.png) [@michael.morello](https://discuss.elastic.co/u/michael.morello)\
**Post date:** [July 7, 2022, 6:38am UTC](https://discuss.elastic.co/t/kubernete-integration-with-fleet/307712/2 "2022-07-07T06:38:41Z")

</div>

Sorry for the late answer. I think this is more a question for the observability folks: [Logs - Discuss the Elastic Stack](https://discuss.elastic.co/c/observability/logs/69)

> I have deployed elastic\_agent pod with DaemonSet in kuber cluster and then register them successfully in Fleet by policy.

Could you provide more details about how agents are deployed? Are you using ECK and the Agent custom resource? Could you share the ECK and Elastic stack versions?

```auto
[elastic_agent.filebeat][error] Error extracting container id - source value does not contain matcher's logs_path '/var/lib/docker/containers/'.

```

Is Docker the CRI deployed on your cluster?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2022, 6:39am UTC](https://discuss.elastic.co/t/kubernete-integration-with-fleet/307712/3 "2022-08-04T06:39:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
