# \[Kubernetes Autodiscover 7.6.2\] Error creating runner from config: No paths were defined for input accessing config

**URL:** <https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 26, 2020, 9:29am UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829 "2020-04-26T09:29:15Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![scriptdb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scriptdb/32/73318_2.png) [@scriptdb](https://discuss.elastic.co/u/scriptdb)\
**Post date:** [April 26, 2020, 9:29am UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829/1 "2020-04-26T09:29:15Z")

</div>

Hello,

I'm running filebeat 7.6.2 on AKS with the following configuration:

```auto
filebeatConfig:
  filebeat.yml: |

    filebeat.autodiscover:
      providers:
        - type: kubernetes
          hints.enabled: false
          templates:
            - condition:
                or:
                  - equals:
                      kubernetes.namespace: stage
                  - equals:
                      kubernetes.namespace: prod          

              config:
                - type: container
                  paths:
                    - /var/lib/docker/containers/${data.kubernetes.container.id}/${data.kubernetes.container.id}-json.log
                  multiline.pattern: '^[[:space:]]'
                  multiline.negate: false
                  multiline.match: after             
                  exclude_lines: ['^.+status":"20.".+path":"\/tenancy\/.+\/authorize.+$','.+200.+(POST|GET).+\/tenancy\/external\/(authorize|resource).+$']

    processors:
    - add_cloud_metadata: ~
    - add_kubernetes_metadata: 
        in_cluster: true
    - drop_event:
        when:
          or:
            - equals:
                kubernetes.container.name: "filebeat"                                
            - equals:
                kubernetes.container.name: "filebeat7"                  
            - equals:
                kubernetes.container.name: "logstash"                     

    output.console:
      pretty: true
      
    logging.to_files: true
    logging.level: info
    logging.files:
      path: /var/log/filebeat
      name: filebeat
      rotateeverybytes: 10485760 # = 10MB
      keepfiles: 7       

```

All modules are disabled.  
Getting the following error in filebeat log:

```auto
> 2020-04-26T08:52:01.056Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: each input must have at least one path defined
> 2020-04-26T08:52:01.056Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: No paths were defined for input accessing config
> 2020-04-26T08:52:01.057Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: each input must have at least one path defined
> 2020-04-26T08:52:01.057Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: each input must have at least one path defined

```

---

<div class="post-metadata">

**Author:** ![scriptdb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scriptdb/32/73318_2.png) [@scriptdb](https://discuss.elastic.co/u/scriptdb)\
**Post date:** [April 27, 2020, 3:17pm UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829/2 "2020-04-27T15:17:25Z")

</div>

Anyone?

---

<div class="post-metadata">

**Author:** ![yosbeleg89](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yosbeleg89/32/53057_2.png) [@yosbeleg89](https://discuss.elastic.co/u/yosbeleg89)\
**Post date:** [May 5, 2020, 6:18pm UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829/3 "2020-05-05T18:18:38Z")

</div>

I'm having the same issue with 7.6.2 and AKS, in my case my config is something like this:

```auto
    filebeat.yml: |
      filebeat.autodiscover:
        providers:
          - type: kubernetes
            templates:
              - condition:
                  equals:
                    kubernetes.labels.app: myapp
                config:
                  - prospectors:
                      paths:
                        - /logs/myapp.*
                      tags: [myapp]
      output.elasticsearch:
        host: '${NODE_NAME}'
        hosts: '${ELASTICSEARCH_HOSTS}'
        username: '${ELASTICSEARCH_USER}'
        password: '${ELASTICSEARCH_PASSWORD}'

```

And in the FileBeat logs I'm seeing these errors:

```auto
2020-05-05T18:11:59.872Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: No paths were defined for input accessing config
2020-05-05T18:12:09.873Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: No paths were defined for input accessing config
2020-05-05T18:12:19.873Z ERROR [autodiscover] cfgfile/list.go:96 Error creating runner from config: No paths were defined for input accessing config

```

---

<div class="post-metadata">

**Author:** ![Hedingber](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@Hedingber](https://discuss.elastic.co/u/Hedingber)\
**Post date:** [May 7, 2020, 7:18am UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829/4 "2020-05-07T07:18:43Z")

</div>

I'm experiencing the same thing, in my case with 7.4.0  
config file is similar - autodiscover - kubernetes - condition (with or, not, contains) - container input etc...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 4, 2020, 7:18am UTC](https://discuss.elastic.co/t/kubernetes-autodiscover-7-6-2-error-creating-runner-from-config-no-paths-were-defined-for-input-accessing-config/229829/5 "2020-06-04T07:18:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
