# Kubernetes Operators Fails with Webhook

**URL:** <https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561>\
**Category:** Elasticsearch\
**Created:** [June 13, 2019, 7:11am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561 "2019-06-13T07:11:12Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dominik-Robert](https://avatars.discourse-cdn.com/v4/letter/d/d9b06d/32.png) [@Dominik-Robert](https://discuss.elastic.co/u/Dominik-Robert)\
**Post date:** [June 13, 2019, 7:11am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/1 "2019-06-13T07:11:12Z")

</div>

Hello,

I want to use the Kubernetes Operator for my own Cluster. But it fails everytime I deploy the Elasticseach Quickstart.

It fails with:

```auto
Error from server (InternalError): error when creating "STDIN": Internal error occurred: failed calling admission webhook "validation.elasticsearch.elastic.co": Post https://elastic-webhook-service.elastic-system.svc:443/validate-elasticsearches?timeout=30s: Service Unavailable

```

Followed this guide for getting started:  
[https://www.elastic.co/guide/en/cloud-on-k8s/current/index.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/index.html)

---

<div class="post-metadata">

**Author:** ![gowsalai](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gowsalai/32/46074_2.png) [@gowsalai](https://discuss.elastic.co/u/gowsalai)\
**Post date:** [June 17, 2019, 7:39am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/2 "2019-06-17T07:39:20Z")

</div>

Hi,

Even i'm getting the same error.

Error from server (InternalError): error when creating "es\_clus.yaml": Internal error occurred: failed calling webhook "[validation.elasticsearch.elastic.co](http://validation.elasticsearch.elastic.co)": Post [https://elastic-webhook-service.elastic-system.svc:443/validate-elasticsearches?timeout=30s:](https://elastic-webhook-service.elastic-system.svc:443/validate-elasticsearches?timeout=30s:) unexpected EOF

---

<div class="post-metadata">

**Author:** ![asp](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@asp](https://discuss.elastic.co/u/asp)\
**Post date:** [June 19, 2019, 7:05am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/3 "2019-06-19T07:05:04Z")

</div>

Hi I am getting same error.

I suppose it has to do something with internet connectivity. My servers are behind a proxy and seems like kubernetes is not aware of it.  
But in the end I need to run it in an air gap system with private registry.

Is your kubernetes cluster also behind a proxy or without internet connectivity?

---

<div class="post-metadata">

**Author:** ![Dominik-Robert](https://avatars.discourse-cdn.com/v4/letter/d/d9b06d/32.png) [@Dominik-Robert](https://discuss.elastic.co/u/Dominik-Robert)\
**Post date:** [June 19, 2019, 10:44am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/4 "2019-06-19T10:44:16Z")

</div>

Ohh Yes Im sitting behind a proxy without internet connection with my cluster. So it can possible depent on that.

Other Dependencies:  
kubernetes v1.14.1  
elastic from this guide:  
[https://www.elastic.co/guide/en/cloud-on-k8s/current/index.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/index.html)

---

<div class="post-metadata">

**Author:** ![kkensy](https://avatars.discourse-cdn.com/v4/letter/k/edb3f5/32.png) [@kkensy](https://discuss.elastic.co/u/kkensy)\
**Post date:** [July 12, 2019, 10:46am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/5 "2019-07-12T10:46:28Z")

</div>

Check this out:

> [@Air Gap System: Internal error occurred: failed calling webhook "validation.elasticsearch.elastic.co": Post https://elastic-webhook-service.elastic-system.svc:443/validate-elasticsearches?timeout=30s: Service Unavailable](https://discuss.elastic.co/t/air-gap-system-internal-error-occurred-failed-calling-webhook-validation-elasticsearch-elastic-co-post-https-elastic-webhook-service-elastic-system-svc-443-validate-elasticsearches-timeout-30s-service-unavailable/186396):
>
> Hi, I am following the quick start guide: [https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html) When I want to deploy the single node elasticsearch I get following error: Internal error occurred: failed calling webhook "validation.elasticsearch.elastic.co": Post https://elastic-webhook-service.elastic-system.svc:443/validate-elasticsearches?timeout=30s: Service Unavailable I assume that the problem is that my cluster is behind a proxy server. It can access a private docker…

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2019, 10:46am UTC](https://discuss.elastic.co/t/kubernetes-operators-fails-with-webhook/185561/6 "2019-08-09T10:46:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
