# Kuromoji plugin error

**URL:** <https://discuss.elastic.co/t/kuromoji-plugin-error/10579>\
**Category:** Elasticsearch\
**Created:** [February 1, 2013, 12:17am UTC](https://discuss.elastic.co/t/kuromoji-plugin-error/10579 "2013-02-01T00:17:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![hemant\_pahilwani](https://avatars.discourse-cdn.com/v4/letter/h/f08c70/32.png) [@hemant\_pahilwani](https://discuss.elastic.co/u/hemant_pahilwani)\
**Post date:** [February 1, 2013, 12:17am UTC](https://discuss.elastic.co/t/kuromoji-plugin-error/10579/1 "2013-02-01T00:17:41Z")

</div>

I have installed kuromoji plugin on elastic search server (bin/plugin  
-install elasticsearch/elasticsearch-analysis-kuromoji/1.1.0) in order to  
analyze japanese texts that are being stored in index. One of the mappings  
in index is:

"japaneseFirstname" : { "type" : "string", "index" : "analyzed", "analyzer"  
: "kuromoji"},

But when i try to insert value in this field, the server throws error. Are  
there any lucene dependencies that have to include on the server?

Caused by: org.elasticsearch.index.mapper.MapperParsingException: Analyzer  
[kuromoji] not found for field [japaneseFirstname]  
at  
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:76)  
at  
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:124)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:261)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:217)  
at  
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:161)  
at  
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:364)  
at org.elasticsearch.index.mapper.MapperService.add(MapperService.java:186)  
at  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.execute(MetaDataCreateIndexService.java:259)  
... 4 more

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![hemant\_pahilwani](https://avatars.discourse-cdn.com/v4/letter/h/f08c70/32.png) [@hemant\_pahilwani](https://discuss.elastic.co/u/hemant_pahilwani)\
**Post date:** [February 1, 2013, 6:24am UTC](https://discuss.elastic.co/t/kuromoji-plugin-error/10579/2 "2013-02-01T06:24:38Z")

</div>

ok never mind. The elastic search version that i was using was causing the  
issue. I had 0.19.10 installed which didn't recognize kuromoji. Updating  
it to latest version resolved the issue.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:53am UTC](https://discuss.elastic.co/t/kuromoji-plugin-error/10579/3 "2017-07-06T02:53:38Z")

</div>


