# Lab 2 Assistance (Observability Fundamentals)

**URL:** <https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958>\
**Category:** Elastic Training\
**Created:** [March 31, 2021, 8:01pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958 "2021-03-31T20:01:24Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jasieltego](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasieltego/32/77950_2.png) [@jasieltego](https://discuss.elastic.co/u/jasieltego)\
**Post date:** [March 31, 2021, 8:01pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/1 "2021-03-31T20:01:24Z")

</div>

I'm stuck at this step, not to much detail is shown to accomplish this.  
Now, edit `filebeat.yml` to configure Filebeat to output to your Elastic Cloud deployment. Insert the following two lines at the end of the config file:

I tried to edit the file with nano, but when I type nano filebeat.yml it opens a blank file, nothing to be replaced. How do I get the file in question?

The instructions say to "nano path/to/filename" but I don't know the path.

---

<div class="post-metadata">

**Author:** ![Romain\_Geffraye](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/romain_geffraye/32/77053_2.png) [@Romain\_Geffraye](https://discuss.elastic.co/u/Romain_Geffraye)\
**Post date:** [March 31, 2021, 8:34pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/2 "2021-03-31T20:34:23Z")

</div>

Hello,

Did you successfully download filebeat?

If you did all the command listed in step 2.1, your current directory should be: `/home/elastic/filebeat-7.12.0-linux-x86_64`

You can then run `nano filebeat.yml` from there.

If this command doesn't work, make sure you're in the correct directory.

Romain

---

<div class="post-metadata">

**Author:** ![jasieltego](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasieltego/32/77950_2.png) [@jasieltego](https://discuss.elastic.co/u/jasieltego)\
**Post date:** [March 31, 2021, 10:52pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/3 "2021-03-31T22:52:19Z")

</div>

Thanks, I see the problem. I did download it but paused it. When I came back I was unaware I had to download it again, it worked. Thanks

However, Now I'm running into an issue step 9, I'm running the command ./filebeat setup  
and I get the following error message  
"elastic@ip-xxx-xx-x-xxx~/filebeat-7.12.0-linux-x86\_64$ ./filebeat setup  
Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
Loaded dashboards  
Setting up ML using setup --machine-learning is going to be removed in 8.0.0. Please use the ML app instead.  
See more: [Machine Learning in the Elastic Stack [7.12] | Elastic](https://www.elastic.co/guide/en/machine-learning/current/index.html)  
Exiting: 1 error: Error setting up ML for nginx\_ecs: 10 errors: ; ; ; ; ; ; ; ; ;  
elastic@ip-xxx-xx-x-xxx:~/filebeat-7.12.0-linux-x86\_64$ "

I do have Kibana running.  
BTW I was able to complete the lab, but wondering why those messages show up

---

<div class="post-metadata">

**Author:** ![Andre\_Murbach\_Maidl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andre_murbach_maidl/32/83508_2.png) [@Andre\_Murbach\_Maidl](https://discuss.elastic.co/u/Andre_Murbach_Maidl)\
**Post date:** [April 1, 2021, 11:46am UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/4 "2021-04-01T11:46:39Z")

</div>

Hi @jasieltego ,

this `Exiting: 1 error: Error setting up ML for nginx_ecs: 10 errors: ; ; ; ; ; ; ; ; ;` is a known issue. You can check more details about it in this link:

> <https://github.com/elastic/beats/issues/22567>
>
> For confirmed bugs, please report:
> Version: 7.10.0
> Operating System: ECK 1.3
> Steps to Reproduce: Upgrade filebeat with nginx module from 7.9.3 to 7.10.0
> While upgrading...

Since this issue does not affect any of the lab steps you can just ignore it and proceed with other lab steps.

Thanks,  
Andre

---

<div class="post-metadata">

**Author:** ![Andre\_Murbach\_Maidl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andre_murbach_maidl/32/83508_2.png) [@Andre\_Murbach\_Maidl](https://discuss.elastic.co/u/Andre_Murbach_Maidl)\
**Post date:** [April 8, 2021, 7:29pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/5 "2021-04-08T19:29:36Z")

</div>

By the way, to avoid this issue you can run the following command:

`./filebeat setup --dashboards --index-management --pipelines`

Best,  
Andre

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2021, 7:30pm UTC](https://discuss.elastic.co/t/lab-2-assistance-observability-fundamentals/268958/6 "2021-05-08T19:30:20Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
