# Lambda created but no data in Elastic Cloud

**URL:** <https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341>\
**Category:** Beats\
**Tags:** functionbeat\
**Created:** [January 8, 2019, 10:38am UTC](https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341 "2019-01-08T10:38:03Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ian\_Morris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ian_morris/32/38168_2.png) [@Ian\_Morris](https://discuss.elastic.co/u/Ian_Morris)\
**Post date:** [January 8, 2019, 10:38am UTC](https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341/1 "2019-01-08T10:38:04Z")

</div>

Hi

functionbeat version 6.5.4

I have just created an Elastic Cloud trial. I am trying to use Functionbeat to send CloudWatch Logs to the Elastic Cloud trial. In this case, the CloudWatch Log I have selected contains CloudTrail log data. I have configured the Functionbeat.yml to the best of my ability. I run the following command to create the Lambda function

**functionbeat.exe -v -e -d "\*" deploy functionbeat4**

The Lambda function creates successfully but I don't get any data in Elastic Cloud. In the CloudWatch Logs for the Functionbeat Lambda function, there are Ping failures and licence errors. For example

**2019-01-08T10:31:32.531Z DEBUG [elasticsearch] elasticsearch/client.go:689 ES Ping(url=https://d7778585dd07464da103a49311302275.eu-west-1.aws.found.io:443)**

**2019-01-08T10:31:32.652Z DEBUG [elasticsearch] elasticsearch/client.go:693 Ping request failed with: 401 Unauthorized: {"error":{"root\_cause":[{"type":"security\_exception","reason":"action [cluster:monitor/main] requires authentication","header":{"WWW-Authenticate":["Bearer realm="security"","Basic realm="security" charset="UTF-8""]}}],"type":"security\_exception","reason":"action [cluster:mo**

**2019-01-08T10:31:32.652Z INFO [license-manager] licenser/manager.go:265 Cannot retrieve license, retrying later, error: error from server, response code: 0**

**2019-01-08T10:31:32.652Z DEBUG [license-manager] licenser/manager.go:274 License is too old, grace time remaining: 44m59.878940032s**

My functionbeat.yml is attached

 ![Capture](https://us1.discourse-cdn.com/elastic/original/3X/6/7/6710ce9d8b6ee2117f2c00daaba1dbc4af1ea28f.jpeg)

Any ideas what the problem could be?

Thanks

---

<div class="post-metadata">

**Author:** ![Ian\_Morris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ian_morris/32/38168_2.png) [@Ian\_Morris](https://discuss.elastic.co/u/Ian_Morris)\
**Post date:** [January 10, 2019, 7:25am UTC](https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341/2 "2019-01-10T07:25:39Z")

</div>

To Functionbeat developer team - I'd really like to get this working as this is a deal breaker for us. We were going to use aws elasticsearch because it already integrates with AWS CloudWatch Logs but I would prefer to use Elastic Cloud but that depends on getting Functionbeat working. I followed the instructions in the documentation to configure the functionbeat.yml so if the configuration is wrong I can provide feedback on anything that is not clear to a user,

---

<div class="post-metadata">

**Author:** ![Ian\_Morris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ian_morris/32/38168_2.png) [@Ian\_Morris](https://discuss.elastic.co/u/Ian_Morris)\
**Post date:** [January 10, 2019, 8:21am UTC](https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341/3 "2019-01-10T08:21:47Z")

</div>

OK, I have resolved it. I had indented the cloud.auth under output.elasticearch because I thought this is where it went. I removed output.elasticearch and now it works

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 30, 2019, 10:21pm UTC](https://discuss.elastic.co/t/lambda-created-but-no-data-in-elastic-cloud/163341/4 "2019-01-30T22:21:51Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
