# Liblog4cxx.so.10 change to liblog4cxx.so.10.gz after started a time

**URL:** https://discuss.elastic.co/t/liblog4cxx-so-10-change-to-liblog4cxx-so-10-gz-after-started-a-time/182169
**Category:** Elasticsearch
**Tags:** elastic-stack-machine-learning
**Created:** [May 22, 2019, 8:10am UTC](https://discuss.elastic.co/t/liblog4cxx-so-10-change-to-liblog4cxx-so-10-gz-after-started-a-time/182169 "2019-05-22T08:10:39Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![0rnito](https://avatars.discourse-cdn.com/v4/letter/0/49beb7/32.png) [@0rnito](https://discuss.elastic.co/u/0rnito)
#### Post date: [May 24, 2019, 11:41am UTC](https://discuss.elastic.co/t/liblog4cxx-so-10-change-to-liblog4cxx-so-10-gz-after-started-a-time/182169/5 "2019-05-24T11:41:20Z")

</div>

> [@org.elasticsearch.bootstrap.StartupException: ElasticsearchException\[Failed to create native process factories for Machine Learning\]; nested: FileNotFoundException\[\\\\.\\pipe\\controller\_log\_13044 (The system cannot find the file specified)\]](https://discuss.elastic.co/t/org-elasticsearch-bootstrap-startupexception-elasticsearchexception-failed-to-create-native-process-factories-for-machine-learning-nested-filenotfoundexception-pipe-controller-log-13044-the-system-cannot-find-the-file-specified/166264):
>
> I am new to Elastic search and facing an issue while installing it. I am getting below exception: org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to create native process factories for Machine Learning]; nested: FileNotFoundException[\.\pipe\controller\_log\_13044 (The system cannot find the file specified)]; Can anyone suggest me what can i do to resolve the same? Thanks & Regards, Priyanka Y.

Nothing of interesting..

File liblog4cxx.so.10 exists on **my** system without changes. I think he is not guilty of anything. I think the system is trying to create something in the /tmp directory for the running Learning Machine, but cannot do it, so the process crashes.  
The problem is that I don't know if I need a learning machine or not? 🤪  
I am trying other temp-directory with owner "elasticsearch", changing version of Java, but don`t understand, why this "very bad" process cannot running. 😡

I will patiently study the documentation. 😇  
If I can understand, I will write here.

---

_[View the full topic](https://discuss.elastic.co/t/liblog4cxx-so-10-change-to-liblog4cxx-so-10-gz-after-started-a-time/182169)._
