# License check warnings and logstash fails to work

**URL:** <https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783>\
**Category:** Logstash\
**Created:** [January 16, 2018, 8:34pm UTC](https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783 "2018-01-16T20:34:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![GSCully](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gscully/32/26104_2.png) [@GSCully](https://discuss.elastic.co/u/GSCully)\
**Post date:** [January 16, 2018, 8:34pm UTC](https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783/1 "2018-01-16T20:34:21Z")

</div>

First off Logstash is not on the cluster it is a seperate vm, (Windows)  
After installing x-pack for monitoring I get an error spamming my console window,  
spamming th logs is this,  
[logstash.licensechecker.licensereader] Running health check to see if an Elasticsearch connection is working {: **healthcheck\_url** =\>[http://localhost:9200/](http://localhost:9200/), :path=\>"/"}  
[2018-01-16T20:24:02,813][WARN][logstash.licensechecker.licensereader] UNEXPECTED POOL ERROR {:e=\>#\<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections\>}  
But the is no setting for heathcheck url that I can find and localhost won't work of course.

config,  
input {  
beats {  
port =\> 5044  
ssl =\> true  
ssl\_certificate\_authorities =\> ["D:\logstash\config\ca\ca.crt"]  
ssl\_certificate =\> "D:\logstash\config\logstash\logstash.crt"  
ssl\_key =\> "D:\logstash\config\logstash\logstash.key"

```
} 

```

}  
output {  
elasticsearch {  
hosts =\> ["[https://xxx:9200](https://xxx:9200)"]  
ssl =\> true  
cacert =\> "D:\logstash\config\ca\ca.crt"

```
}

```

stdout { codec =\> rubydebug }

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 16, 2018, 8:43pm UTC](https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783/2 "2018-01-16T20:43:54Z")

</div>

Isn't this the same as [Can’t start logstash after x-pack installation](https://discuss.elastic.co/t/can-t-start-logstash-after-x-pack-installation/115353/8)?

---

<div class="post-metadata">

**Author:** ![GSCully](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gscully/32/26104_2.png) [@GSCully](https://discuss.elastic.co/u/GSCully)\
**Post date:** [January 16, 2018, 9:22pm UTC](https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783/3 "2018-01-16T21:22:58Z")

</div>

yes, sorry about that.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 16, 2018, 9:38pm UTC](https://discuss.elastic.co/t/license-check-warnings-and-logstash-fails-to-work/115783/4 "2018-01-16T21:38:39Z")

</div>


