# License could not be determined error

**URL:** https://discuss.elastic.co/t/license-could-not-be-determined-error/55184
**Category:** Elasticsearch
**Tags:** license
**Created:** [July 11, 2016, 11:20am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184 "2016-07-11T11:20:35Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![mrvincnezo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrvincnezo/32/10829_2.png) [@mrvincnezo](https://discuss.elastic.co/u/mrvincnezo)
#### Post date: [July 11, 2016, 11:20am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/1 "2016-07-11T11:20:35Z")

</div>

After installing X-Pack into elasticsearch & kibana (both are alpha4), when I ran kibana for the first time (after X-Pack installation) I get a login screen but it is disabled! Below the login screen there is a message saying "Login is currently disabled because the license could not be determined."

It is the first time I am installing X-Pack on this machine.

Any help will be appreciated.

---

<div class="post-metadata">

### Author: ![mrvincnezo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrvincnezo/32/10829_2.png) [@mrvincnezo](https://discuss.elastic.co/u/mrvincnezo)
#### Post date: [July 11, 2016, 11:33am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/2 "2016-07-11T11:33:50Z")

</div>

I think it is related to elasticsearch's cluster that I deployed. I installed X-Pack only on one of the cluster's machines. I disabled the cluster and left with one machine only (the one that has X-Pack installed on) and it resolved the issue.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 13, 2016, 4:01am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/3 "2016-07-13T04:01:57Z")

</div>

It needs to be installed on _all_ nodes in the cluster.

---

<div class="post-metadata">

### Author: ![mrvincnezo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrvincnezo/32/10829_2.png) [@mrvincnezo](https://discuss.elastic.co/u/mrvincnezo)
#### Post date: [July 13, 2016, 6:52am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/4 "2016-07-13T06:52:08Z")

</div>

Thanks. That exactly what the problem was.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 1, 2016, 9:42pm UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/6 "2016-08-01T21:42:22Z")

</div>

Please start your own thread for this 🙂

---

<div class="post-metadata">

### Author: ![cmk1523](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cmk1523/32/6474_2.png) [@cmk1523](https://discuss.elastic.co/u/cmk1523)
#### Post date: [November 9, 2016, 1:10am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/7 "2016-11-09T01:10:07Z")

</div>

Same issue here. I'm using the full regular 5.0.0 release for both Elastic, Kibana and X-Pack... however I am on Ubuntu so I did the Debian installs for all and I've changed my host to 192.168.29.236.

Going to [http://192.168.29.236:9200](http://192.168.29.236:9200) reports everything is fine.

When going to [http://192.168.29.236:5601](http://192.168.29.236:5601) I'm getting "Login is currently disabled because the license could not be determined. Please check that Elasticsearch is running, then refresh this page." red label error when trying to run Kibana for the first time.

Perhaps there's an issue with not configuring Kibana on localhost first?

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [November 9, 2016, 9:46am UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/8 "2016-11-09T09:46:44Z")

</div>

Please open up a new thread instead of reviving old ones

Also share your license info, to make sure it is not expired.. see [https://www.elastic.co/guide/en/x-pack/5.0/listing-licenses.html](https://www.elastic.co/guide/en/x-pack/5.0/listing-licenses.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:40pm UTC](https://discuss.elastic.co/t/license-could-not-be-determined-error/55184/9 "2017-07-06T13:40:08Z")

</div>


