# License doesn't work with Elasticsearch (Kibana) v5

**URL:** https://discuss.elastic.co/t/license-doesnt-work-with-elasticsearch-kibana-v5/60939
**Category:** Kibana
**Created:** [September 19, 2016, 8:12pm UTC](https://discuss.elastic.co/t/license-doesnt-work-with-elasticsearch-kibana-v5/60939 "2016-09-19T20:12:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![j16r](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/j16r/32/9676_2.png) [@j16r](https://discuss.elastic.co/u/j16r)
#### Post date: [September 19, 2016, 8:12pm UTC](https://discuss.elastic.co/t/license-doesnt-work-with-elasticsearch-kibana-v5/60939/1 "2016-09-19T20:12:34Z")

</div>

I'm unable to log into my Kibana dashboard right now because the license has expired, when I try to set my license however I get the error:

`{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"unknown setting [index.license.expiry_date_in_millis] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"}],"type":"illegal_argument_exception","reason":"unknown setting [index.license.expiry_date_in_millis] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"},"status":400}`

unknown setting [index.license.expiry\_date\_in\_millis]

Is there a way to get newer licenses for v5?

---

<div class="post-metadata">

### Author: ![thomasneirynck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomasneirynck/32/23313_2.png) [@thomasneirynck](https://discuss.elastic.co/u/thomasneirynck)
#### Post date: [September 21, 2016, 2:04pm UTC](https://discuss.elastic.co/t/license-doesnt-work-with-elasticsearch-kibana-v5/60939/2 "2016-09-21T14:04:37Z")

</div>

Hi j16r,

Kibana just tries to validate the license, which is why the login panel is disabled.

I would take that question to the x-pack forum ([https://discuss.elastic.co/c/x-pack](https://discuss.elastic.co/c/x-pack)) and post that error message there. This is likely due to a version mismatch like you suggest. FWIW, I think that setting was introduced in v5.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:38pm UTC](https://discuss.elastic.co/t/license-doesnt-work-with-elasticsearch-kibana-v5/60939/3 "2017-07-06T13:38:36Z")

</div>


