# License error with Filebeat 6.7.1 Docker image and AWS ElasticSearch

**URL:** <https://discuss.elastic.co/t/license-error-with-filebeat-6-7-1-docker-image-and-aws-elasticsearch/180003>\
**Category:** Beats\
**Tags:** license, filebeat\
**Created:** [May 7, 2019, 2:22pm UTC](https://discuss.elastic.co/t/license-error-with-filebeat-6-7-1-docker-image-and-aws-elasticsearch/180003 "2019-05-07T14:22:16Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![spiffytech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spiffytech/32/28062_2.png) [@spiffytech](https://discuss.elastic.co/u/spiffytech)\
**Post date:** [May 7, 2019, 2:22pm UTC](https://discuss.elastic.co/t/license-error-with-filebeat-6-7-1-docker-image-and-aws-elasticsearch/180003/1 "2019-05-07T14:22:16Z")

</div>

I'm trying to upgrade my Kubernetes cluster to use the 6.7.1 Docker image and I'm getting the following error when the container starts:

```auto
Failed to connect to backoff(myserver.es.amazonaws.com:443)): Connection marked as failed because the onConnect callback failed: cannot retrieve the elasticsearch license: unauthorized access, could not connect to the xpack endpoint, verify your credentials

```

How can I use the OSS Filebeat distribution in Docker/Kubernetes?

---

<div class="post-metadata">

**Author:** ![martinr\_ubi](https://avatars.discourse-cdn.com/v4/letter/m/b5e925/32.png) [@martinr\_ubi](https://discuss.elastic.co/u/martinr_ubi)\
**Post date:** [May 8, 2019, 7:16am UTC](https://discuss.elastic.co/t/license-error-with-filebeat-6-7-1-docker-image-and-aws-elasticsearch/180003/2 "2019-05-08T07:16:07Z")

</div>

Hi,

By using the oss distribution of the docker images. Or maybe I misunderstand the question and you have a specific issue? They are listed on:  
[https://www.docker.elastic.co/#filebeat-6-7-1-oss](https://www.docker.elastic.co/#filebeat-6-7-1-oss)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 5, 2019, 7:16am UTC](https://discuss.elastic.co/t/license-error-with-filebeat-6-7-1-docker-image-and-aws-elasticsearch/180003/3 "2019-06-05T07:16:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
