# License Question: x-pack Modules

**URL:** <https://discuss.elastic.co/t/license-question-x-pack-modules/296975>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 11, 2022, 1:15pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975 "2022-02-11T13:15:04Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jarbird](https://avatars.discourse-cdn.com/v4/letter/j/5daacb/32.png) [@Jarbird](https://discuss.elastic.co/u/Jarbird)\
**Post date:** [February 11, 2022, 1:15pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/1 "2022-02-11T13:15:04Z")

</div>

Hello,

I have been struggling to get the netflow module working. The error I keep ending up with is:

```auto
2022-02-11T07:49:28.539-0500 ERROR instance/beat.go:1015 Exiting: Failed to start crawler: creating module reloader failed: error checking input configuration: Error creating input. No such input type exist: 'netflow'
Exiting: Failed to start crawler: creating module reloader failed: error checking input configuration: Error creating input. No such input type exist: 'netflow'

```

I spent more time than I'd like to admit shuffling files and directories around. I read that there are differences between the OSS (Apache-2?) licensed features and the elastic licensed features. My distro has the OSS (Apache-2?) version installed. Does that simply mean that it does not come with the x-pack modules, or does it mean that filebeat itself cannot use them?

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [February 11, 2022, 2:18pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/2 "2022-02-11T14:18:34Z")

</div>

The OSS version of Filbeat does not include the netflow input. But you can download the non-OSS version of Filebeat for free: [Download Filebeat • Lightweight Log Analysis | Elastic](https://www.elastic.co/downloads/beats/filebeat)

---

<div class="post-metadata">

**Author:** ![Jarbird](https://avatars.discourse-cdn.com/v4/letter/j/5daacb/32.png) [@Jarbird](https://discuss.elastic.co/u/Jarbird)\
**Post date:** [February 11, 2022, 4:51pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/3 "2022-02-11T16:51:27Z")

</div>

Okay, does this mean it is not about _where_ the x-pack files are, but instead, it is about if the installed filebeat instance supports them and/or a specific module in this case netflow?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 11, 2022, 9:41pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/4 "2022-02-11T21:41:33Z")

</div>

To get that module you need to download the default distribution, which includes non-apache licensed code in it.

---

<div class="post-metadata">

**Author:** ![Jarbird](https://avatars.discourse-cdn.com/v4/letter/j/5daacb/32.png) [@Jarbird](https://discuss.elastic.co/u/Jarbird)\
**Post date:** [February 11, 2022, 9:42pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/5 "2022-02-11T21:42:19Z")

</div>

Great, thanks I am trying that now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 11, 2022, 11:42pm UTC](https://discuss.elastic.co/t/license-question-x-pack-modules/296975/6 "2022-03-11T23:42:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
