# License upgrade failed on windows

**URL:** https://discuss.elastic.co/t/license-upgrade-failed-on-windows/113605
**Category:** Elasticsearch
**Created:** [December 29, 2017, 5:16pm UTC](https://discuss.elastic.co/t/license-upgrade-failed-on-windows/113605 "2017-12-29T17:16:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Francesca\_P](https://avatars.discourse-cdn.com/v4/letter/f/7feea3/32.png) [@Francesca\_P](https://discuss.elastic.co/u/Francesca_P)
#### Post date: [December 29, 2017, 5:16pm UTC](https://discuss.elastic.co/t/license-upgrade-failed-on-windows/113605/1 "2017-12-29T17:16:39Z")

</div>

Hi,  
I get the following message, when I go to install the update on windows7:

> {  
> "acknowledged": false,  
> "license\_status": "valid",  
> "acknowledge": {  
> "message": """This license update requires acknowledgement. To acknowledge the license, please read the following messages and update the license again, this time with the "acknowledge=true" parameter:""",  
> "watcher": [  
> "Watcher will be disabled"  
> ],  
> "logstash": [  
> "Logstash specific APIs will be disabled, but you can continue to manage and poll stored configurations"  
> ],  
> "security": [  
> "The following X-Pack security functionality will be disabled: authentication, authorization, ip filtering, and auditing. Please restart your node after applying the license.",  
> "Field and document level access control will be disabled.",  
> "Custom realms will be ignored."  
> ],  
> "monitoring": [  
> """  
> Multi-cluster support is disabled for clusters with [BASIC] license. If you are  
> running multiple clusters, users won't be able to access the clusters with  
> [BASIC] licenses from within a single X-Pack Kibana instance. You will have to deploy a  
> separate and dedicated X-pack Kibana instance for each [BASIC] cluster you wish to monitor.  
> """,  
> "Automatic index cleanup is locked to 7 days for clusters with [BASIC] license."  
> ],  
> "graph": [  
> "Graph will be disabled"  
> ],  
> "ml": [  
> "Machine learning will be disabled"  
> ]  
> }  
> }

I used the kibana console to update the license:

> PUT \_xpack/license  
> //content of the licence.json file

How can I solve from kibana console?

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [December 31, 2017, 2:40am UTC](https://discuss.elastic.co/t/license-upgrade-failed-on-windows/113605/2 "2017-12-31T02:40:10Z")

</div>

Hi,

Are you trying to install basic license? - If so - you need to acknowledge that you are downgrading your license. If you can run this - from your terminal - it should work.

```auto
curl -XPUT -u elastic ’http://localhost:9200/_xpack/license?acknowledge=true' -H ‘content-type: application/json’ -d @basic.json

```

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 28, 2018, 2:40am UTC](https://discuss.elastic.co/t/license-upgrade-failed-on-windows/113605/3 "2018-01-28T02:40:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
