# Lifecycle error

**URL:** <https://discuss.elastic.co/t/lifecycle-error/289533>\
**Category:** Elasticsearch\
**Tags:** ilm-index-lifecycle-management\
**Created:** [November 18, 2021, 6:48am UTC](https://discuss.elastic.co/t/lifecycle-error/289533 "2021-11-18T06:48:33Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mrchile](https://avatars.discourse-cdn.com/v4/letter/m/a6a055/32.png) [@mrchile](https://discuss.elastic.co/u/mrchile)\
**Post date:** [November 18, 2021, 6:48am UTC](https://discuss.elastic.co/t/lifecycle-error/289533/1 "2021-11-18T06:48:33Z")

</div>

No rollover info found for [name\_index-%{+YYYY.MM.dd}-000001] with rollover target [index-alias], the index has not yet rolled over with that target. The next day I get this error. On the first day of operation, no errors are observed. How can this situation be resolved?  
I created config "index-000001"

```auto
PUT all_index-000001
{
  "aliases": {
    "index-alias": {
      "is_write_index": true
    }
  }
}

```

I create aliases "index-alias"

```auto
POST _aliases
{
    "actions" : [
        {
           "add" : {
                 "index" : "all_index-000001",
                 "alias" : "index-alias",
                 "is_write_index" : true
            }
        }
]
}

```

Add template

```auto
PUT /_index_template/all_template
{
  "index_patterns" : ["log*"],
  "priority" : 1,
  "template": {
    "settings" : {
    "index.lifecycle.name": "log_hot_warm_policy", 
    "index.lifecycle.rollover_alias": "index-alias",
    "number_of_shards" : 5
},
    "aliases" : {
  "index-alias": {}
  },
"mappings" : {
      "_doc": {
    "_routing": {
      "required": false
    },
    "numeric_detection": false,
    "dynamic_date_formats": [
      "strict_date_optional_time",
      "yyyy/MM/dd HH:mm:ss Z||yyyy/MM/dd Z"
    ],
    "_source": {
      "excludes": [],
      "includes": [],
      "enabled": true
    },
    "dynamic": true,
    "dynamic_templates": [],
    "date_detection": true
}
    }         
  }
}

```

Added a configuration, I will be glad if you comment on it, I thought it would help in solving the problem

```auto
PUT /_cluster/settings
{
  "persistent" : {
    "cluster.routing.allocation.disk.threshold_enabled" : "true"
  }
}
 
PUT /_cluster/settings
{
"persistent": {
"action.auto_create_index": true
}
}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 16, 2021, 6:48am UTC](https://discuss.elastic.co/t/lifecycle-error/289533/2 "2021-12-16T06:48:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
