# Load Kibana dashboard for MySQL

**URL:** <https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [March 22, 2018, 9:35am UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152 "2018-03-22T09:35:44Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![oerner](https://avatars.discourse-cdn.com/v4/letter/o/5daacb/32.png) [@oerner](https://discuss.elastic.co/u/oerner)\
**Post date:** [March 22, 2018, 9:35am UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152/1 "2018-03-22T09:35:44Z")

</div>

Hi,  
I'm getting a file not found error when trying to load Kibana dashboard.  
Metricbeat version: 6.2.2  
Kibana version . : 5.5.2  
Elasticsearch : 5.5.2

Elasticsearch and Kibana are AWS services, Metricbeat is installed on EC2.

command: sudo metricbeat setup --dashboards

here is the log:  
2018-03-22T09:09:20.700Z INFO instance/beat.go:213 Setup Beat: metricbeat; Version: 6.2.2  
2018-03-22T09:09:20.701Z INFO elasticsearch/client.go:145 Elasticsearch url: https:/\<\>:443  
2018-03-22T09:09:20.703Z INFO pipeline/module.go:76 Beat name: worker-dev-impv3-0-14495297052-203  
2018-03-22T09:09:20.703Z INFO elasticsearch/client.go:145 Elasticsearch url: https://\<\>:443  
2018-03-22T09:09:20.791Z INFO elasticsearch/client.go:690 Connected to Elasticsearch version 5.5.2  
2018-03-22T09:09:21.981Z ERROR instance/beat.go:667 Exiting: Error importing Kibana dashboards: fail to import the dashboards in Elasticsearch: Error importing directory /usr/share/metricbeat/kibana: Failed to import dashboard: Failed to load directory /usr/share/metricbeat/kibana/5/dashboard:  
error loading /usr/share/metricbeat/kibana/5/dashboard/Metricbeat-uWSGI.json: open /usr/share/metricbeat/kibana/5/visualization/ **a5058e70-f0ae-11e7-b9ff-9f96241065de.json** : no such file or directory

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [March 22, 2018, 12:24pm UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152/2 "2018-03-22T12:24:21Z")

</div>

This looks like a bug with the Kibana 5 dashboards. The [Metricbeat-uWSGI.json](https://github.com/elastic/beats/blob/v6.2.2/metricbeat/module/uwsgi/_meta/kibana/5/dashboard/Metricbeat-uWSGI.json#L8) file is referencing visualization panels by UUID, but those panels were [given friendly names](https://github.com/elastic/beats/tree/v6.2.2/metricbeat/module/uwsgi/_meta/kibana/5/visualization). So probably the UUID references need replaced with the dashboard names.

Can you please [open a new issue](https://github.com/elastic/beats/issues/new) for this?

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [March 22, 2018, 12:25pm UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152/3 "2018-03-22T12:25:19Z")

</div>

I think as a work around (if you are not using uWSGI) you can delete the `/usr/share/metricbeat/kibana/5/dashboard/Metricbeat-uWSGI.json` file and it will proceed with installing the dashboards.

---

<div class="post-metadata">

**Author:** ![oerner](https://avatars.discourse-cdn.com/v4/letter/o/5daacb/32.png) [@oerner](https://discuss.elastic.co/u/oerner)\
**Post date:** [March 22, 2018, 1:13pm UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152/4 "2018-03-22T13:13:28Z")

</div>

> [@oerner](#):
>
> sudo metricbeat setup --dashboards

Hi Andrew,  
thanks much for prompt reply. workaround simply works.

Oded.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 19, 2018, 1:13pm UTC](https://discuss.elastic.co/t/load-kibana-dashboard-for-mysql/125152/5 "2018-04-19T13:13:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
