# (LoadError) no such file to load -- gssapi

**URL:** <https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619>\
**Category:** Logstash\
**Created:** [July 29, 2019, 7:18am UTC](https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619 "2019-07-29T07:18:45Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Darshan\_Parab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/darshan_parab/32/51098_2.png) [@Darshan\_Parab](https://discuss.elastic.co/u/Darshan_Parab)\
**Post date:** [July 29, 2019, 7:18am UTC](https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619/1 "2019-07-29T07:18:45Z")

</div>

Hi,

I have configured webhdfs output as show below. I'm getting error that says I don't have gssapi conf webhdfs output.

Pipeline:

> input {  
> beats {  
> port =\> 5044  
> }  
> }
> 
> filter {  
> }
> 
> output {  
> webhdfs {  
> host =\> "hdfsserver"  
> port =\> 8020  
> path =\> "/user/hadoop/elktest/helloworld.log"  
> user =\> "hadoop"  
> use\_kerberos\_auth =\> true  
> kerberos\_keytab =\> "/opt/hadoop/hadoop.keytab"  
> }  
> }

Error:

> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | [2019-07-29T07:15:23,530][INFO][logstash.pipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, \>"pipeline.batch.delay"=\>50}  
> hdfs\_logstash.1.ggkrawhiqo23@SIDCAPASPARK2 | start at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:176  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | warning: thread "[main]-pipeline-manager" terminated with exception (report\_on\_exception is true):  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | prepare\_client at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs 3.0.6/lib/logstash/outputs/webhdfs\_helper.rb:27  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs-3.0.6/lib/logstash/outputs/webhdfs.rb:153  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | LoadError: no such file to load -- gssapi  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register at org/logstash/config/ir/compiler/OutputStrategyExt.java:106  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | require at org/jruby/RubyKernel.java:987  
> hdfs\_logstash.1.ggkrawhiqo23@SIDCAPASPARK2 | [2019-07-29T07:14:58,659][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | require at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/polyglot-0.3.5/lib/polyglot.rb:65  
> hdfs\_logstash.1.ggkrawhiqo23@SIDCAPASPARK2 | [2019-07-29T07:14:58,718][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) no such file to load -- gssapi  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register at org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:48  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | prepare\_client at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs-3.0.6/lib/logstash/outputs/webhdfs\_helper.rb:27  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register\_plugin at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:259  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs-3.0.6/lib/logstash/outputs/webhdfs.rb:153  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register at org/logstash/config/ir/compiler/OutputStrategyExt.java:106  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | each at org/jruby/RubyArray.java:1792  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register at org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:48  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | register\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register\_plugin at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:259  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | maybe\_setup\_out\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:611  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | each at org/jruby/RubyArray.java:1792  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | start\_workers at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:280  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | register\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | run at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:217  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | maybe\_setup\_out\_plugins at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:611  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | start at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:176  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | start\_workers at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:280  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | run at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:217  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | start at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:176  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | [2019-07-29T07:16:13,587][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
> hdfs\_logstash.1.xt1qpca4z7rn@SIDCAPASPARK2 | [2019-07-29T07:16:13,672][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) no such file to load -- gssapi  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | [2019-07-29T07:15:23,801][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
> hdfs\_logstash.1.0ip85vorm1yx@SIDCAPASPARK2 | [2019-07-29T07:15:23,908][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) no such file to load -- gssapi

---

<div class="post-metadata">

**Author:** ![Darshan\_Parab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/darshan_parab/32/51098_2.png) [@Darshan\_Parab](https://discuss.elastic.co/u/Darshan_Parab)\
**Post date:** [July 29, 2019, 12:25pm UTC](https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619/2 "2019-07-29T12:25:34Z")

</div>

I was able to fix the issue using below mentioned discussion thread.

> [@Directions for installing gssapi to use logstash webhdfs plugin with kerberos](https://discuss.elastic.co/t/directions-for-installing-gssapi-to-use-logstash-webhdfs-plugin-with-kerberos/185049/2):
>
> Here is an update -\> I have the following modifications (yes its still messy, but you will get the idea) to get me to the point where I get another known error: Dockerfile: FROM [docker.elastic.co/logstash/logstash:6.4.2](http://docker.elastic.co/logstash/logstash:6.4.2) ARG GIT\_SHA ENV GIT\_SHA=${GIT\_SHA} USER 0 WORKDIR /usr/share/logstash ENV PATH=/usr/share/logstash/bin:$PATH Ensure Logstash has a UTF-8 locale available. RUN locale-gen en\_US.UTF-8 ENV LANG='en\_US.UTF-8' LC\_ALL='en\_US.UTF-8' ENV LANG=en\_US.UTF-8 LANGUAGE=en\_US.UTF-8 …

> [@Logstash webhdfs example with Kerberos enabled hadoop cluster](https://discuss.elastic.co/t/logstash-webhdfs-example-with-kerberos-enabled-hadoop-cluster/51941):
>
> configured the webhdfs\_helper.rb that client.kerberos = true /client.kerberos\_keytab="xxx" and installed the gssapi but still have such problem: Webhdfs check request failed. (namenode: 10.0.0.37:14000, Exception: undefined method read\_uint32' for #\<FFI::MemoryPointer address=0xd69f20 size=4\>) {:level=\>:error} The error reported is: undefined methodread\_uint32' for #\<FFI::MemoryPointer address=0xd69f20 size=4\>

However, now I'm getting below mentioned error.

````auto
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | No Kerberos credentials available: Invalid UID in persistent keyring name
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | )
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | [2019-07-29T12:20:24,356][ERROR][logstash.javapipeline] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<WebHDFS::KerberosError: gss_init_sec_context did not return GSS_S_COMPLETE: Unspecified GSS failure. Minor code may provide more information
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | No Kerberos credentials available: Invalid UID in persistent keyring name
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | >, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/webhdfs-0.8.0/lib/webhdfs/client_v1.rb:323:in `request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/webhdfs-0.8.0/lib/webhdfs/client_v1.rb:275:in `operate_requests'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/webhdfs-0.8.0/lib/webhdfs/client_v1.rb:138:in `list'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs-3.0.6/lib/logstash/outputs/webhdfs_helper.rb:49:in `test_client'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-webhdfs-3.0.6/lib/logstash/outputs/webhdfs.rb:155:in `register'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:106:in `register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:48:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:192:in `block in register_plugins'", "org/jruby/RubyArray.java:1792:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:191:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:462:in `maybe_setup_out_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:204:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:146:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:105:in `block in start'"], :thread=>"#<Thread:0x49a8e1b3 run>"}
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | [2019-07-29T12:20:24,374][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | [2019-07-29T12:20:24,519][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
hdfs_logstash.1.i8axxr7tdhsq@SIDCAPASPARK2 | [2019-07-29T12:20:29,606][INFO][logstash.runner] Logstash shut down.```
````

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 26, 2019, 12:25pm UTC](https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619/3 "2019-08-26T12:25:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
