# LockReleaseFailedException

**URL:** https://discuss.elastic.co/t/lockreleasefailedexception/14532
**Category:** Elasticsearch
**Created:** [November 22, 2013, 5:29am UTC](https://discuss.elastic.co/t/lockreleasefailedexception/14532 "2013-11-22T05:29:57Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Ram\_Viswanadha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ram_viswanadha/32/1888_2.png) [@Ram\_Viswanadha](https://discuss.elastic.co/u/Ram_Viswanadha)
#### Post date: [November 22, 2013, 5:29am UTC](https://discuss.elastic.co/t/lockreleasefailedexception/14532/1 "2013-11-22T05:29:57Z")

</div>

Hi,  
I got this exception in our production servers and the cluster went down.  
Any idea what might have caused it and how to prevent this from happening  
in the future?

[2013-11-22 03:17:57,600][WARN][cluster.action.shard]  
[savvy\_es\_chef\_node\_1] sending failed shard for [events\_addon\_v3][4],  
node[LYjH3PdYTh6WVE2hL5K0zQ], [P], s[INITIALIZING], reason [Failed to start  
shard, message [IndexShardGatewayRecoveryException[[events\_addon\_v3][4]  
failed recovery]; nested:  
EngineCreationFailureException[[events\_addon\_v3][4] failed to create  
engine]; nested: LockReleaseFailedException[Cannot forcefully unlock a  
NativeFSLock which is held by another indexer component:  
/mnt/elasticsearch/data/savvy\_es\_prod/nodes/0/indices/events\_addon\_v3/4/index/write.lock];  
]]

--  
Best Regards,

Ram Viswanadha

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [November 22, 2013, 8:28am UTC](https://discuss.elastic.co/t/lockreleasefailedexception/14532/2 "2013-11-22T08:28:47Z")

</div>

Hey,

do you run another elasticsearch instance on the same data, which was not  
stoppde (use 'jps' command to see running java instances).  
Is the /mnt mountpoint a network share, maybe NFS?  
You could also use 'lsof' command to find out, which process has opened the  
write.lock file.

--Alex

On Fri, Nov 22, 2013 at 6:29 AM, Ram Viswanadha [rviswanadha@gmail.com](mailto:rviswanadha@gmail.com)wrote:

> Hi,  
> I got this exception in our production servers and the cluster went down.  
> Any idea what might have caused it and how to prevent this from happening  
> in the future?
> 
> [2013-11-22 03:17:57,600][WARN][cluster.action.shard]  
> [savvy\_es\_chef\_node\_1] sending failed shard for [events\_addon\_v3][4],  
> node[LYjH3PdYTh6WVE2hL5K0zQ], [P], s[INITIALIZING], reason [Failed to start  
> shard, message [IndexShardGatewayRecoveryException[[events\_addon\_v3][4]  
> failed recovery]; nested:  
> EngineCreationFailureException[[events\_addon\_v3][4] failed to create  
> engine]; nested: LockReleaseFailedException[Cannot forcefully unlock a  
> NativeFSLock which is held by another indexer component:  
> /mnt/elasticsearch/data/savvy\_es\_prod/nodes/0/indices/events\_addon\_v3/4/index/write.lock];  
> ]]
> 
> --  
> Best Regards,
> 
> Ram Viswanadha
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![Ram\_Viswanadha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ram_viswanadha/32/1888_2.png) [@Ram\_Viswanadha](https://discuss.elastic.co/u/Ram_Viswanadha)
#### Post date: [November 22, 2013, 7:12pm UTC](https://discuss.elastic.co/t/lockreleasefailedexception/14532/3 "2013-11-22T19:12:25Z")

</div>

Hi Alex,

> do you run another elasticsearch instance on the same data, which was not  
> stoppde (use 'jps' command to see running java instances).

No  
ubuntu@ip1:~$ jps  
28983 Jps

ubuntu@ip2:~$ jps  
25772 Jps

> Is the /mnt mountpoint a network share, maybe NFS?

No. /mnt is IO optimized EBS volume.

> You could also use 'lsof' command to find out, which process has opened  
> the write.lock file.
> 
> will try that if it happens next time

> --Alex
> 
> On Fri, Nov 22, 2013 at 6:29 AM, Ram Viswanadha \<[rvisw...@gmail.com](mailto:rvisw...@gmail.com)\<javascript:\>
> 
> > wrote:
> 
> > Hi,  
> > I got this exception in our production servers and the cluster went down.  
> > Any idea what might have caused it and how to prevent this from happening  
> > in the future?
> > 
> > [2013-11-22 03:17:57,600][WARN][cluster.action.shard]  
> > [savvy\_es\_chef\_node\_1] sending failed shard for [events\_addon\_v3][4],  
> > node[LYjH3PdYTh6WVE2hL5K0zQ], [P], s[INITIALIZING], reason [Failed to start  
> > shard, message [IndexShardGatewayRecoveryException[[events\_addon\_v3][4]  
> > failed recovery]; nested:  
> > EngineCreationFailureException[[events\_addon\_v3][4] failed to create  
> > engine]; nested: LockReleaseFailedException[Cannot forcefully unlock a  
> > NativeFSLock which is held by another indexer component:  
> > /mnt/elasticsearch/data/savvy\_es\_prod/nodes/0/indices/events\_addon\_v3/4/index/write.lock];  
> > ]]
> > 
> > --  
> > Best Regards,
> > 
> > Ram Viswanadha
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 2:05am UTC](https://discuss.elastic.co/t/lockreleasefailedexception/14532/4 "2017-07-06T02:05:18Z")

</div>


