# Log not show in kibana after filter in logstash

**URL:** <https://discuss.elastic.co/t/log-not-show-in-kibana-after-filter-in-logstash/145952>\
**Category:** Logstash\
**Created:** [August 24, 2018, 5:37pm UTC](https://discuss.elastic.co/t/log-not-show-in-kibana-after-filter-in-logstash/145952 "2018-08-24T17:37:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tuyen\_Quang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tuyen_quang/32/34797_2.png) [@Tuyen\_Quang](https://discuss.elastic.co/u/Tuyen_Quang)\
**Post date:** [August 24, 2018, 5:37pm UTC](https://discuss.elastic.co/t/log-not-show-in-kibana-after-filter-in-logstash/145952/1 "2018-08-24T17:37:26Z")

</div>

Hi all,

I'm using filter for parsing docker log of python app. but after use grok for matching fields log no longer show in kibana dashboard.

> if [type] == "log" {  
> grok {  
> match =\> {  
> "log" =\> "%{TIMESTAMP\_ISO8601:timestamp},%{NOTSPACE} %{LOGLEVEL:Level} | %{DATA:tx\_id}: %{DATA:txid} | %{DATA:client\_id}: %{DATA:clientid} | [%{DATA:proc\_name}] - %{GREEDYDATA:message}"  
> }  
> break\_on\_match =\> false  
> remove\_tag =\> ["\_grokparsefailure"]  
> add\_field =\> {  
> "logtype" =\> "dockerInfo"  
> }  
> }  
> grok {  
> match =\> {  
> "log" =\> "%{TIMESTAMP\_ISO8601:timestamp},%{NOTSPACE} %{LOGLEVEL:Level} | %{DATA:tx\_id}: %{DATA:txid} | %{DATA:client\_id}: %{DATA:clientid} | [%{DATA:proc\_name}] - %{GREEDYDATA:message}"  
> }  
> break\_on\_match =\> false  
> remove\_tag =\> ["\_grokparsefailure"]  
> add\_field =\> {  
> "logtype" =\> "dockerErr"  
> }  
> }
> 
> date {  
> "match" =\> ["timestamp", "YYYY-MM-dd HH:mm:ss,SSS"]  
> remove\_field =\> ["timestamp"]  
> target =\> "@timestamp"  
> }
> 
> }

sample data 🙂

> 2018-08-24 22:24:24,002,2 ERROR | tx\_id: ofgjbqbnz7 | client\_id: None | [authorization\_api.py:123] - Unable to connect to OAuth API: 401 Unauthorized: The server could not verify that you are authorized to access the URL requested. You either supplied the wrong credentials (e.g. a bad password), or your browser doesn't understand how to supply the credentials required.  
> 2018-08-24 22:24:30,954,954 INFO | tx\_id: 0hfzak0eff | client\_id: None | [common\_functions.py:136] - Retrieving oauth2\_client\_data

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 21, 2018, 5:47pm UTC](https://discuss.elastic.co/t/log-not-show-in-kibana-after-filter-in-logstash/145952/2 "2018-09-21T17:47:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
