# Log stash configuration file to push delta of data from SQL Server using JDBC Importer to elastic search

**URL:** https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313
**Category:** Elasticsearch
**Created:** [August 14, 2018, 9:44am UTC](https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313 "2018-08-14T09:44:01Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![pavitra21](https://avatars.discourse-cdn.com/v4/letter/p/7993a0/32.png) [@pavitra21](https://discuss.elastic.co/u/pavitra21)
#### Post date: [August 14, 2018, 9:44am UTC](https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313/1 "2018-08-14T09:44:02Z")

</div>

my configuration file

input{  
jdbc {  
jdbc\_connection\_string =\> "jdbc:mysql://localhost:3307/demo"  
jdbc\_user =\> "root"  
jdbc\_password =\> "pavitra"  
jdbc\_validate\_connection =\> true  
jdbc\_driver\_library =\> "mysql-connector-java-5.1.16-bin.jar"  
jdbc\_driver\_class =\> "com.mysql.jdbc.Driver"  
statement =\> "Select \* from city"  
}  
}

output{  
stdout { codec =\> json\_lines }  
}

running it using  
C:\Program Files (x86)\logstash-6.3.2\>bin\logstash -f E:\data\db.conf

and getting the following error  
Sending Logstash's logs to C:/Program Files (x86)/logstash-6.3.2/logs which is now configured via log4j2.properties  
[2018-08-16T14:44:16,263][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2018-08-16T14:44:16,841][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"6.3.2"}  
[2018-08-16T14:44:18,448][INFO][logstash.pipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50}  
[2018-08-16T14:44:18,776][INFO][logstash.pipeline] Pipeline started successfully {:pipeline\_id=\>"main", :thread=\>"#\<Thread:0x66f1950d sleep\>"}  
[2018-08-16T14:44:18,823][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>[]}  
[2018-08-16T14:44:19,136][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2018-08-16T14:44:19,760][ERROR][logstash.inputs.jdbc] Unable to connect to database. Tried 1 times {:error\_message=\>"Java::ComMysqlJdbcExceptionsJdbc4::MySQLNonTransientConnectionException: Client does not support authentication protocol requested by server; consider upgrading MySQL client"}  
[2018-08-16T14:44:19,776][ERROR][logstash.pipeline] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_connection\_string=\>"jdbc:mysql://localhost:3307/demo", jdbc\_user=\>"root", jdbc\_password=\>, jdbc\_validate\_connection=\>true, jdbc\_driver\_library=\>"C:\Program Files (x86)\logstash-6.3.2\bin\mysql-connector-java-5.1.16-bin.jar", jdbc\_driver\_class=\>"com.mysql.jdbc.Driver", statement=\>"Select \* from city", id=\>"7f79a2db500811024d0d70ea793d3b1084698b8a9c2bc810fecdc5025be8d629", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_a4fd7c9e-3173-4b5d-8abb-57ba5b85a376", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, parameters=\>{"sql\_last\_value"=\>1970-01-01 05:30:00 +0530}, last\_run\_metadata\_path=\>"C:\Users\pavitra malpani/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true\>  
Error: Java::ComMysqlJdbcExceptionsJdbc4::MySQLNonTransientConnectionException: Client does not support authentication protocol requested by server; consider upgrading MySQL client  
Exception: Sequel::DatabaseConnectionError  
Stack: java.lang.reflect.Constructor.newInstance(java/lang/reflect/Constructor.java:423)  
com.mysql.jdbc.Util.handleNewInstance(com/mysql/jdbc/Util.java:411)  
com.mysql.jdbc.Util.getInstance(com/mysql/jdbc/Util.java:386)  
com.mysql.jdbc.SQLError.createSQLException(com/mysql/jdbc/SQLError.java:1013)  
com.mysql.jdbc.MysqlIO.checkErrorPacket(com/mysql/jdbc/MysqlIO.java:3597)  
com.mysql.jdbc.MysqlIO.checkErrorPacket(com/mysql/jdbc/MysqlIO.java:3529)  
com.mysql.jdbc.MysqlIO.checkErrorPacket(com/mysql/jdbc/MysqlIO.java:935)  
com.mysql.jdbc.MysqlIO.secureAuth411(com/mysql/jdbc/MysqlIO.java:4101)  
com.mysql.jdbc.MysqlIO.doHandshake(com/mysql/jdbc/MysqlIO.java:1300)  
com.mysql.jdbc.ConnectionImpl.coreConnect(com/mysql/jdbc/ConnectionImpl.java:2337)  
com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(com/mysql/jdbc/ConnectionImpl.java:2370)  
com.mysql.jdbc.ConnectionImpl.createNewIO(com/mysql/jdbc/ConnectionImpl.java:2154)  
com.mysql.jdbc.ConnectionImpl.(com/mysql/jdbc/ConnectionImpl.java:792)  
com.mysql.jdbc.JDBC4Connection.(com/mysql/jdbc/JDBC4Connection.java:47)  
java.lang.reflect.Constructor.newInstance(java/lang/reflect/Constructor.java:423)  
com.mysql.jdbc.Util.handleNewInstance(com/mysql/jdbc/Util.java:411)  
com.mysql.jdbc.ConnectionImpl.getInstance(com/mysql/jdbc/ConnectionImpl.java:381)  
com.mysql.jdbc.NonRegisteringDriver.connect(com/mysql/jdbc/NonRegisteringDriver.java:305)  
java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)

---

<div class="post-metadata">

### Author: ![Silen\_logs](https://avatars.discourse-cdn.com/v4/letter/s/ed655f/32.png) [@Silen\_logs](https://discuss.elastic.co/u/Silen_logs)
#### Post date: [August 14, 2018, 2:30pm UTC](https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313/2 "2018-08-14T14:30:50Z")

</div>

> [@pavitra21](#):
>
> jdbc\_driver\_class = "com.mysql.jdbc.Driver"

Hello !

You have a syntax error on your configuration file. The driver line expect a "\>" clause.

Incorrect: jdbc\_driver\_class = "com.mysql.jdbc.Driver".  
Correct: jdbc\_driver\_class =\> "com.mysql.jdbc.Driver".

---

<div class="post-metadata">

### Author: ![pavitra21](https://avatars.discourse-cdn.com/v4/letter/p/7993a0/32.png) [@pavitra21](https://discuss.elastic.co/u/pavitra21)
#### Post date: [August 16, 2018, 9:23am UTC](https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313/3 "2018-08-16T09:23:14Z")

</div>

ohkk thank you

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 13, 2018, 9:23am UTC](https://discuss.elastic.co/t/log-stash-configuration-file-to-push-delta-of-data-from-sql-server-using-jdbc-importer-to-elastic-search/144313/4 "2018-09-13T09:23:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
