# Loghstash service is not getting started going in continues restart having error: Logstash stopped processing because of an error: (NoMethodError) private method \`run' called for #\<LogStash::Runner:0x32a806ef\>

**URL:** https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799
**Category:** Logstash
**Created:** [June 10, 2026, 3:21pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799 "2026-06-10T15:21:35Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 3:21pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/1 "2026-06-10T15:21:35Z")

</div>

loghstash service is not getting started going in continues restart.

Error:  
Logstash stopped processing because of an error: (NoMethodError) private method `run' called for #<LogStash::Runner:0x32a806ef> Jun 10 16:15:03 logstash: org.jruby.exceptions.NoMethodError: (NoMethodError) private method `run' called for #LogStash::Runner:0x32a806ef  
logstash: at usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
logstash: at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]

bin/logstash --version  
Using bundled JDK: /usr/share/logstash/jdk  
logstash 7.17.2

OS : Redhat 7.9

Verified all config and logstash.yml still issue persist.

Even tried re-installation of the logstash giving same error.

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 3:27pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/2 "2026-06-10T15:27:37Z")

</div>

[root@logstash]# sudo -u logstash /usr/share/logstash/bin/logstash --path.settings="/etc/logstash"  
Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[FATAL] 2026-06-10 16:25:27.944 [main] Logstash - Logstash stopped processing because of an error: (NoMethodError) private method `run' called for #<LogStash::Runner:0x5bf48697> org.jruby.exceptions.NoMethodError: (NoMethodError) private method `run' called for #LogStash::Runner:0x5bf48697  
at usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]  
[root@logstash]#

---

<div class="post-metadata">

### Author: ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)
#### Post date: [June 10, 2026, 3:33pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/3 "2026-06-10T15:33:19Z")

</div>

Is this when you run any .conf file or only for a particular .conf file?  
Have you try to run a simple .conf file with test data?  
Something like this:

```auto
input {
  generator {
       message => 'colvalue1, colvalue2, colvalue3'
       count => 1
  }
}
filter{
}
output {
    stdout { codec => rubydebug{ metadata => true}} 
}

```

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 3:48pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/4 "2026-06-10T15:48:44Z")

</div>

Added sample.conf in conf.d and retested, behaving same.

Can we test specific conf file? share me command I don't have any of such.

We are using pipeline.yml

[root@conf.d]# sudo -u logstash /usr/share/logstash/bin/logstash --path.settings="/etc/logstash"  
Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[FATAL] 2026-06-10 16:46:32.522 [main] Logstash- Logstash stopped processing because of an error: (NoMethodError) private method `run' called for #<LogStash::Runner:0x49c9a814> org.jruby.exceptions.NoMethodError: (NoMethodError) private method `run' called for #LogStash::Runner:0x49c9a814  
at usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]  
[root@conf.d]# cat simple.conf  
input {  
generator {  
message =\> 'colvalue1, colvalue2, colvalue3'  
count =\> 1  
}  
}  
filter{  
}  
output {  
stdout { codec =\> rubydebug{ metadata =\> true}}  
}  
[root@conf.d]# pwd  
/etc/logstash/conf.d  
[root@conf.d]#

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 3:59pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/5 "2026-06-10T15:59:23Z")

</div>

I did changes in one of my conf as suggested,

input {  
pipeline {  
address =\> TSO\_Logs  
}  
}

filter {  
}

output {  
stdout { codec =\> rubydebug{ metadata =\> true}}  
}

Still facing same issue.

Means its not specific to any conf

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 4:13pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/6 "2026-06-10T16:13:00Z")

</div>

sudo -u logstash /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/simple.conf

Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[FATAL] 2026-06-10 17:10:07.781 [main] Logstash - Logstash stopped processing because of an error: (NoMethodError) private method `run' called for #<LogStash::Runner:0x32a806ef> org.jruby.exceptions.NoMethodError: (NoMethodError) private method `run' called for #LogStash::Runner:0x32a806ef  
at usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]  
[root@conf.d]#  
[root@conf.d]# cat /etc/logstash/conf.d/simple.conf  
input {  
generator {  
message =\> 'colvalue1, colvalue2, colvalue3'  
count =\> 1  
}  
}  
filter{  
}  
output {  
stdout { codec =\> rubydebug{ metadata =\> true}}  
}  
[root@conf.d]#

---

<div class="post-metadata">

### Author: ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)
#### Post date: [June 10, 2026, 4:49pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/7 "2026-06-10T16:49:59Z")

</div>

Have you tried to reinstall LS? Just make \*.conf files backup

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 5:04pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/8 "2026-06-10T17:04:33Z")

</div>

> [@ashish.jagtap](#):
>
> NoMethodError

Yes, I did re-installation still facing same issue.

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 10, 2026, 5:21pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/9 "2026-06-10T17:21:15Z")

</div>

More commands hit to narrow down issue.

[root@ logstash]# /usr/share/logstash/bin/logstash -e 'input { stdin {} } output { stdout {} }'

Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[FATAL] 2026-06-10 18:16:04.538 [main] Logstash - Logstash stopped processing because of an error: (NoMethodError) private method `run' called for #<LogStash::Runner:0x61e04048> org.jruby.exceptions.NoMethodError: (NoMethodError) private method `run' called for #LogStash::Runner:0x61e04048  
at usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]  
[root@logstash]#

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [June 10, 2026, 7:35pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/10 "2026-06-10T19:35:49Z")

</div>

> [@ashish.jagtap](#):
>
> loghstash service is not getting started going in continues restart.

Did it used to run and stopped or it never ran?

Also, did it run as a service before or you run it through the command line?

---

<div class="post-metadata">

### Author: ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)
#### Post date: [June 11, 2026, 2:11am UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/11 "2026-06-11T02:11:32Z")

</div>

1. Which plugins do you use?
2. Have you try to stop LS service, kill LS process if exists, run the tarbal version, without installation?
3. Have you reviewed logstash.yml, pipelines.yml, startup.options, .conf?
4. When you removed LS rpm, have you cleaned directories:  
/usr/share/logstash/  
/var/lib/logstash/  
/etc/logstash/ - make backup this directory before reinstallation
5. Have you tried to set debug level in logstash.yml?  
`log.level: fatal`  
If still no trace, then enable this:  
`config.debug: true`

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 11, 2026, 11:24am UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/12 "2026-06-11T11:24:28Z")

</div>

Issue got auto resolved in midnight, Haven't done any changes.

I had removed newly added Elastic node from Logstash configuration, that was not worked yesterday but in early morning Logstash started automatically

Just confirm me is that ok to have 5 Elastic servers in cluster?  
1 logstash and 1 Kibana.

Startup logs:

Jun 11 06:52:33 hostname logstash: at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:93) ~[?:?]  
Jun 11 06:52:35 hostname logstash: Using bundled JDK: /usr/share/logstash/jdk  
Jun 11 06:52:37 hostname logstash: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
Jun 11 06:52:52 hostname logstash: Sending Logstash logs to /apps/logstash\_logs which is now configured via log4j2.properties  
Jun 11 06:52:53 hostname logstash: [2026-06-11T06:52:53,019][INFO][logstash.runner] Log4j configuration path used is: /etc/logstash/log4j2.properties  
Jun 11 06:52:53 hostname logstash: [2026-06-11T06:52:53,076][INFO][logstash.runner] Starting Logstash  
{"logstash.version"=\>"7.17.2", "jruby.version"=\>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.14.1+1 on 11.0.14.1+1 +indy +jit [linux-x86\_64]"}  
Jun 11 06:52:53 hostname logstash: [2026-06-11T06:52:53,077][INFO][logstash.runner] JVM bootstrap flag  
s: [-Xms16g, -Xmx16g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.io.tmpdir=/apps/logstash\_logs, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -Djruby.regexp.interruptible=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -agentpath:/dynatrace/oneagent/agent/bin/1.333.55.20260317-092136/linux-x86-64/liboneagentjava.so=loglevelcon=none,datastorage=/dynatrace/data,lo  
gdir=/dynatrace/logs]

I don't understand why its going for dynatrace afent : **agentpath:/dynatrace/oneagent/agent/bin/1.333.55.20260317-092136/linux-x86-64/liboneagentjava.so=loglevelcon=none,datastorage=/dynatrace/data,lo  
gdir=/dynatrace/logs**

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [June 11, 2026, 1:36pm UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/13 "2026-06-11T13:36:05Z")

</div>

> [@ashish.jagtap](#):
>
> I don't understand why its going for dynatrace afent : **agentpath:/dynatrace/oneagent/agent/bin/1.333.55.20260317-092136/linux-x86-64/liboneagentjava.so=loglevelcon=none,datastorage=/dynatrace/data,lo  
> gdir=/dynatrace/logs**

This is unrelated to Logstash, it is a java agent attached on Logstash JVM.

Elastic does not recommend to use Java Agents on the JVM of their products because they can cause issues, this is mostly related to Elasticsearch but it probably also applies to Logstash.

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 12, 2026, 5:32am UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/14 "2026-06-12T05:32:01Z")

</div>

> [@leandrojmp](#):
>
> This is unrelated to Logstash, it is a java agent attached on Logstash JVM.
> 
> Elastic does not recommend to use Java Agents on the JVM of their products because they can cause issues, this is mostly related to Elasticsearch but it probably also applies to Logstash.

Thanks for the confirmation. Will stop agents over Elasticsearch evironment.

Can yo confirm if it is Ok to have 5 nodes of Elasticsearch in cluster [1 Primary and 4 Secondary Nodes having replica count 2]

Or we have to keep 4 nodes [1 Primary and 3 Secondary Nodes having replica count 2]

---

<div class="post-metadata">

### Author: ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)
#### Post date: [June 12, 2026, 5:47am UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/15 "2026-06-12T05:47:26Z")

</div>

Maybe this is a problem: _`datastorage=/dynatrace/data`_

@leandrojmp Is it possible to isolate JVMS between agents? Every agent to use own specified JVM, data&log&temp directory, especially ELK is the all in one package.  
Any other issues perhaps?

---

<div class="post-metadata">

### Author: ![ashish.jagtap](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@ashish.jagtap](https://discuss.elastic.co/u/ashish.jagtap)
#### Post date: [June 12, 2026, 6:47am UTC](https://discuss.elastic.co/t/loghstash-service-is-not-getting-started-going-in-continues-restart-having-error-logstash-stopped-processing-because-of-an-error-nomethoderror-private-method-run-called-for-logstash-0x32a806ef/386799/16 "2026-06-12T06:47:06Z")

</div>

Nothing more, Thank you
