# Login is currently disabled after security on

**URL:** https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298
**Category:** Kibana
**Created:** [October 6, 2018, 6:40am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298 "2018-10-06T06:40:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![af615dbd55cac2cacf32](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@af615dbd55cac2cacf32](https://discuss.elastic.co/u/af615dbd55cac2cacf32)
#### Post date: [October 6, 2018, 6:40am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298/1 "2018-10-06T06:40:45Z")

</div>

now I am trying to initiate x-pack Security but seeing some errors.

in Kibana: (i am seeing below error while screen showing "login" feature)  
"Login is currently disabled. Administrators should consult the Kibana logs for more details."

I looked at the kibana log what the kibana page advised to me, and below errors were observed.

{"type":"log","@timestamp":"2018-10-06T06:30:56Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}  
{"type":"log","@timestamp":"2018-10-06T06:31:26Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}  
{"type":"log","@timestamp":"2018-10-06T06:31:56Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}  
{"type":"log","@timestamp":"2018-10-06T06:32:26Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security\_exception\",\"reason\":\"missing authentication token for REST request [/\_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}

what i did before i experienced above errors were as below.

1. xpack.security.enabled: true
2. set password for "elastic","kibana" and "logstash-system" users, then put passwords to ELK configurations.
3. restarted ELK.

Please advice what i should do to resolve.

Please don't tell me to security setting to "off". I am trying to make this works. ☹

Thank you!

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [October 6, 2018, 6:11pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298/2 "2018-10-06T18:11:10Z")

</div>

Hi ,

Have you read our [documentation](https://www.elastic.co/guide/en/elastic-stack-overview/current/security-getting-started.html)? It looks like you are on the right track, you just need to configure kibana. Please start from [here](https://www.elastic.co/guide/en/elastic-stack-overview/current/get-started-kibana-user.html)

---

<div class="post-metadata">

### Author: ![af615dbd55cac2cacf32](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@af615dbd55cac2cacf32](https://discuss.elastic.co/u/af615dbd55cac2cacf32)
#### Post date: [October 7, 2018, 7:20am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298/3 "2018-10-07T07:20:23Z")

</div>

thank you for your reply, ikakavas. the problem was solved by below solution what you advised.

- i removed elasticsearch.username and elasticsearch.password lines from kibana.yml.
- i created keystore then add username and password there.
- restarted kibana. "login is currently disabled" was gone on the kibana login page. i typed username and password which just created in the keystore. logged in successfully! 🙂

thanks alot!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 4, 2018, 7:20am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-after-security-on/151298/4 "2018-11-04T07:20:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
