# Login is currently disabled because the license could not be determined. Please check that Elasticsearch has the X-Pack plugin installed and is reachable

**URL:** https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306
**Category:** Elasticsearch
**Created:** [July 12, 2019, 8:46pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306 "2019-07-12T20:46:12Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![aishu](https://avatars.discourse-cdn.com/v4/letter/a/3be4f8/32.png) [@aishu](https://discuss.elastic.co/u/aishu)
#### Post date: [July 12, 2019, 8:46pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/1 "2019-07-12T20:46:12Z")

</div>

please help,I recently Installed x-pack to the elk server and i am getting license is currently disabled error and i checked the x-pack it is in trial version and the license is still active.  
root@niconet04:/usr/share/kibana/bin# ./kibana  
log [20:41:59.036] [info][status][plugin:kibana@5.6.8] Status changed from uninitialized to green - Ready  
log [20:41:59.208] [info][status][plugin:elasticsearch@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:41:59.278] [info][status][plugin:xpack\_main@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:41:59.340] [info][status][plugin:graph@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:41:59.365] [info][status][plugin:monitoring@5.6.8] Status changed from uninitialized to green - Ready  
log [20:41:59.693] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml  
log [20:41:59.706] [info][status][plugin:reporting@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:41:59.800] [info][status][plugin:security@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:41:59.801] [warning][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml  
log [20:41:59.864] [warning][security] Session cookies will be transmitted over insecure connections. This is not recommended.  
log [20:42:00.010] [info][status][plugin:searchprofiler@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:42:00.019] [info][status][plugin:ml@5.6.8] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [20:42:00.088] [error][status][plugin:xpack\_main@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.096] [error][status][plugin:graph@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.102] [error][status][plugin:reporting@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.107] [error][status][plugin:security@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.108] [error][status][plugin:searchprofiler@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.113] [error][status][plugin:ml@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.128] [error][status][plugin:elasticsearch@5.6.8] Status changed from yellow to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.139] [info][status][plugin:ml@5.6.8] Status changed from red to green - Ready  
log [20:42:00.151] [error][status][plugin:tilemap@5.6.8] Status changed from uninitialized to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.157] [error][status][plugin:watcher@5.6.8] Status changed from uninitialized to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.198] [info][status][plugin:grokdebugger@5.6.8] Status changed from uninitialized to green - Ready  
log [20:42:00.205] [error][status][plugin:upgrade@5.6.8] Status changed from uninitialized to red - Elasticsearch is still initializing the kibana index.  
log [20:42:00.266] [info][status][plugin:console@5.6.8] Status changed from uninitialized to green - Ready  
log [20:42:00.290] [info][status][plugin:metrics@5.6.8] Status changed from uninitialized to green - Ready  
log [20:42:00.827] [info][status][plugin:timelion@5.6.8] Status changed from uninitialized to green - Ready  
log [20:42:00.930] [fatal] Port 5601 is already in use. Another instance of Kibana may be running!  
FATAL Port 5601 is already in use. Another instance of Kibana may be running!

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [July 16, 2019, 7:32am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/2 "2019-07-16T07:32:38Z")

</div>

> [@aishu](#):
>
> i am getting license is currently disabled error

That is not what the error actually says:

```auto
the license could not be determined.
Please check that Elasticsearch ... is reachable

```

This indicates that Kibana cannot connect to Elasticsearch.  
Something about your config is incorrect.

> [@aishu](#):
>
> log [20:42:00.930] [fatal] Port 5601 is already in use. Another instance of Kibana may be running!  
> FATAL Port 5601 is already in use. Another instance of Kibana may be running!

The problem in _this log_ is that Kibana is already running. It has nothing to do with the license.

---

<div class="post-metadata">

### Author: ![aishu](https://avatars.discourse-cdn.com/v4/letter/a/3be4f8/32.png) [@aishu](https://discuss.elastic.co/u/aishu)
#### Post date: [July 18, 2019, 1:36pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/3 "2019-07-18T13:36:25Z")

</div>

Hi

I have another issue when i am trying to access elastic search from another machine i am getting refused connection error and i tried to change the host to _global_ and restarted the elastic search and after one minute it is failed to start and i changed the host to 0.0.0.0, i am getting the same error so i changed it to local it is working fine.Please advice?

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [July 18, 2019, 2:31pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/4 "2019-07-18T14:31:47Z")

</div>

I suspect you are running into Elasitcsearch's [Bootstrap Checks](https://www.elastic.co/guide/en/elasticsearch/reference/7.1/bootstrap-checks.html). Please check the elasticsearch logs.

I see from your original post that you are using version 5.6.8 - that's a very old version, and is no longer supported. If this is a new project then I would strongly recommend you install a newer version such as 7.2.

---

<div class="post-metadata">

### Author: ![aishu](https://avatars.discourse-cdn.com/v4/letter/a/3be4f8/32.png) [@aishu](https://discuss.elastic.co/u/aishu)
#### Post date: [July 18, 2019, 2:37pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/5 "2019-07-18T14:37:07Z")

</div>

Are there any steps to upgrade all the three (kibana,elastic search,logstash) i am using 4.4.0-119-generic #143-Ubuntu SMP Mon Apr 2 16:08:24 UTC 2018 x86\_64 x86\_64 x86\_64 GNU/Linux

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [July 23, 2019, 12:49am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/6 "2019-07-23T00:49:08Z")

</div>

- [Upgrade to 7.2](https://www.elastic.co/guide/en/elastic-stack/7.2/index.html)

_or_

- [Upgrade to 6.8](https://www.elastic.co/guide/en/elastic-stack/6.8/index.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 20, 2019, 12:49am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable/190306/7 "2019-08-20T00:49:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
