# Login is currently disabled.issue

**URL:** https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003
**Category:** Elasticsearch
**Created:** [May 8, 2018, 12:37pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003 "2018-05-08T12:37:24Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 12:37pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/1 "2018-05-08T12:37:25Z")

</div>

I am trying elastic 6 and elastic is running fine. But Kibana Login page is disabled. I didn't found anything in the kibana logs to resolve this issue.

 ![1111](https://us1.discourse-cdn.com/elastic/original/3X/5/a/5a46a9885b86fd8c88c5d3f55247ac428510467f.png)

Got following error too

[root@915453-elastic2 elasticsearch]# /usr/share/elasticsearch/bin/x-pack/setup-passwords interactive

Connection failure to: [http://127.0.0.1:9200/\_xpack/security/\_authenticate?pretty](http://127.0.0.1:9200/_xpack/security/_authenticate?pretty) failed: Connection refused (Connection refused)

ERROR: Failed to connect to elasticsearch at [http://127.0.0.1:9200/\_xpack/security/\_authenticate?pretty](http://127.0.0.1:9200/_xpack/security/_authenticate?pretty). Is the URL correct and elasticsearch running?  
[root@915453-elastic2 elasticsearch]#

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [May 8, 2018, 12:48pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/2 "2018-05-08T12:48:11Z")

</div>

> [@nuwan](#):
>
> I am trying elastic 6 and elastic is running fine.

So is Elasticsearch starting up fine with no errors in the logs? How do you access it ?

Where is Elasticsearch installed ? Is it on the same machine as Kibana ?

I see you access Kibana on `172.24.36.217` but `setup-passwords` is trying to access Elasticsearch at localhost which means that your `elasticsearch.yml` contains 127.0.0.1 as the host.

The problem you're facing is that Kibana can't access Elasticsearch, and the reason for that will be in your kibana logs.

Can you share the relevant parts of your config and logs?

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 12:53pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/3 "2018-05-08T12:53:00Z")

</div>

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2018-05-08 08:32:56 EDT; 18min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 78337 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 78337 (code=exited, status=1/FAILURE)

May 08 08:32:49 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: Started Elasticsearch.  
May 08 08:32:49 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: Starting Elasticsearch...  
May 08 08:32:56 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
May 08 08:32:56 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: Unit elasticsearch.service entered failed state.  
May 08 08:32:56 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: elasticsearch.service failed

Kibana also installed in same machine

which config and logs do you require ?

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 12:54pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/4 "2018-05-08T12:54:56Z")

</div>

[root@915453-elastic2 elasticsearch]# cat elasticsearch.yml

# ======================== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [https://www.elastic.co/guide/en/elasticsearch/reference/index.html](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

#cluster.name: newfrontierdata-cluster

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

#node.name: [915453-Elastic2.newfrontierdata.com](http://915453-Elastic2.newfrontierdata.com)

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /var/lib/elasticsearch

# 

# Path to log files:

# 

path.logs: /var/log/elasticsearch

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

#network.host: 0.0.0.0

# 

# Set a custom port for HTTP:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when new node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

#discovery.zen.ping.unicast.hosts: ["172.24.32.216", "172.24.36.217" , "172.24.36.218", "172.24.32.209"]

# 

# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):

# 

#discovery.zen.minimum\_master\_nodes: 4

# 

# For more information, consult the zen discovery module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true

xpack.security.transport.ssl.enabled: true

set license type (follow is the trial license)  
xpack.license.self\_generated.type: trial

# set Monitoring (enabled)

xpack.monitoring.enabled: true

# set Security (disabled)

xpack.security.enabled: false

# set Watcher (disabled)

xpack.watcher.enabled: false

# set Machine learning (disabled)

xpack.ml.enabled: false

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [May 8, 2018, 1:02pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/5 "2018-05-08T13:02:47Z")

</div>

Please make the effort to format your post to be as readable as possible - there's a live preview panel for exactly this reasons.  
Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.  
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.  
Config files should be entered as preformatted text (the \</\> button) so that they display correctly and can be read by the people who are trying help you.

> [@nuwan](#):
>
> May 08 08:32:56 [915453-elastic2.newfrontierdata.com](http://915453-elastic2.newfrontierdata.com) systemd[1]: elasticsearch.service failed

Elasticsearch is not running fine as it failed to start. Kibana can't connect to it for that reason, and this is the problem you need to address first.

Check the elasticsearch log (`/var/log/elasticsearch/elasticsearch.log`) for indications on what is actually wrong.

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 4:03pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/6 "2018-05-08T16:03:00Z")

</div>

Sorry for that.I'm going to uninstall X-pack and reinstall it.

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [May 8, 2018, 4:51pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/7 "2018-05-08T16:51:41Z")

</div>

> [@nuwan](#):
>
> I'm going to uninstall X-pack and reinstall it.

I think a better approach might be to check the logs and see what's failing. Feel free to share the relevant parts here so that we can assist you. If this is a configuration error for instance, reinstalling X-Pack won't accomplish much with regards to solving your issue.

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 5:24pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/8 "2018-05-08T17:24:25Z")

</div>

Yes absolutely correct . Problem fixed

xpack.license.self\_generated.type: trial  
xpack.monitoring.enabled: true

# enable Security

xpack.security.enabled: true  
xpack.watcher.enabled: false  
xpack.ml.enabled: false

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [May 8, 2018, 5:25pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/9 "2018-05-08T17:25:05Z")

</div>

Thank you very much for helping me ........😀

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 5, 2018, 5:25pm UTC](https://discuss.elastic.co/t/login-is-currently-disabled-issue/131003/10 "2018-06-05T17:25:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
