# Logstash 1.5.1 crashing

**URL:** https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134
**Category:** Logstash
**Created:** [June 22, 2015, 10:50pm UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134 "2015-06-22T22:50:18Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Sam\_Barham](https://avatars.discourse-cdn.com/v4/letter/s/e495f1/32.png) [@Sam\_Barham](https://discuss.elastic.co/u/Sam_Barham)
#### Post date: [June 22, 2015, 10:50pm UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/1 "2015-06-22T22:50:19Z")

</div>

I'm just installed logstash 1.5.1 on a similar VM to one that runs logstash 1.4.2 without issue. On the new VM, however, logstash 1.5.1 crashes on startup with the following error logs:

NotImplementedError: stat.st\_gid unsupported or native support failed to load  
gid at org/jruby/RubyFileStat.java:247  
atomic\_write at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/helper.rb:45  
\_sincedb\_write at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:234  
sincedb\_write at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:204  
teardown at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-0.1.10/lib/logstash/inputs/file.rb:151  
inputworker at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202  
synchronize at org/jruby/ext/thread/Mutex.java:149  
inputworker at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202  
start\_input at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:170

Any ideas what the issue might be? I'm trawling through the code now, but I don't know ruby so it's slow going.

---

<div class="post-metadata">

### Author: ![Sam\_Barham](https://avatars.discourse-cdn.com/v4/letter/s/e495f1/32.png) [@Sam\_Barham](https://discuss.elastic.co/u/Sam_Barham)
#### Post date: [June 22, 2015, 11:06pm UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/2 "2015-06-22T23:06:13Z")

</div>

I'm getting closer. It is _creating_ the .sincdb files, but writing nothing into them...

---

<div class="post-metadata">

### Author: ![Sam\_Barham](https://avatars.discourse-cdn.com/v4/letter/s/e495f1/32.png) [@Sam\_Barham](https://discuss.elastic.co/u/Sam_Barham)
#### Post date: [June 22, 2015, 11:11pm UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/3 "2015-06-22T23:11:04Z")

</div>

Sometimes I get the following error instead:  
NotImplementedError: block device detection unsupported or native support failed to load  
blockdev? at org/jruby/RubyFileTest.java:67  
device? at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/helper.rb:67  
\_sincedb\_write at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:231  
sincedb\_write at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:204  
teardown at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-0.1.10/lib/logstash/inputs/file.rb:151  
inputworker at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202  
synchronize at org/jruby/ext/thread/Mutex.java:149  
inputworker at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202  
start\_input at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:170

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 23, 2015, 5:52am UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/4 "2015-06-23T05:52:18Z")

</div>

That's pretty unusual, I'll ask an LS dev to comment.

---

<div class="post-metadata">

### Author: ![suyograo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suyograo/32/44898_2.png) [@suyograo](https://discuss.elastic.co/u/suyograo)
#### Post date: [June 23, 2015, 6:02am UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/5 "2015-06-23T06:02:25Z")

</div>

Hi, we've seen this issue in Ubuntu 14.04 and Oracle JDK. This is not a Logstash issue per se, but a JDK platform issue. The workaround mentioned in the github issue works for most folks. See [https://github.com/elastic/logstash/issues/3127#issuecomment-101068714](https://github.com/elastic/logstash/issues/3127#issuecomment-101068714)

---

<div class="post-metadata">

### Author: ![Sam\_Barham](https://avatars.discourse-cdn.com/v4/letter/s/e495f1/32.png) [@Sam\_Barham](https://discuss.elastic.co/u/Sam_Barham)
#### Post date: [June 23, 2015, 9:56pm UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/6 "2015-06-23T21:56:37Z")

</div>

Thank you, that's exactly what I needed

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:36am UTC](https://discuss.elastic.co/t/logstash-1-5-1-crashing/24134/7 "2017-07-06T05:36:42Z")

</div>


