# Logstash 2.1.3 - how to config retry on failure

**URL:** <https://discuss.elastic.co/t/logstash-2-1-3-how-to-config-retry-on-failure/129165>\
**Category:** Logstash\
**Created:** [April 23, 2018, 7:05pm UTC](https://discuss.elastic.co/t/logstash-2-1-3-how-to-config-retry-on-failure/129165 "2018-04-23T19:05:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mt.michael](https://avatars.discourse-cdn.com/v4/letter/m/9dc877/32.png) [@mt.michael](https://discuss.elastic.co/u/mt.michael)\
**Post date:** [April 23, 2018, 7:05pm UTC](https://discuss.elastic.co/t/logstash-2-1-3-how-to-config-retry-on-failure/129165/1 "2018-04-23T19:05:17Z")

</div>

I'm using 2.1.3 and got an error on the log saying "Attempted to send a bulk request to Elasticsearch configured at host..... but an error occurred and it failed! Are you sure you can reach elasticsearch from this machine using the configuration provided?"

It mentioned about these as well "reload\_connections=\>false, :retry\_on\_failure=\>false, :reload\_on\_failure=\>false"

I can't find anything reload or retry params. Just wonder how can we set the retry on failure in our config file?

---

<div class="post-metadata">

**Author:** ![mt.michael](https://avatars.discourse-cdn.com/v4/letter/m/9dc877/32.png) [@mt.michael](https://discuss.elastic.co/u/mt.michael)\
**Post date:** [April 23, 2018, 7:25pm UTC](https://discuss.elastic.co/t/logstash-2-1-3-how-to-config-retry-on-failure/129165/2 "2018-04-23T19:25:20Z")

</div>

Tried with retry\_on\_failure=\> true and reload\_on\_failure =\> true in the output section in the conf but it can't start up saying the following:

{:timestamp=\>"2018-04-23T15:09:57.373000-0400", :message=\>"Unknown setting 'retry\_on\_failure' for elasticsearch", :level=\>:error}  
{:timestamp=\>"2018-04-23T15:09:57.379000-0400", :message=\>"Unknown setting 'reload\_on\_failure' for elasticsearch", :level=\>:error}

Not sure the exact name for the retry setting or maybe it's something to deal with the java command line that I need to attach special parameter?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2018, 7:25pm UTC](https://discuss.elastic.co/t/logstash-2-1-3-how-to-config-retry-on-failure/129165/3 "2018-05-21T19:25:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
