# Logstash 2.3.3 on windows "=1.0 was unexpected at this time" error

**URL:** <https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135>\
**Category:** Logstash\
**Created:** [June 17, 2016, 9:21am UTC](https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135 "2016-06-17T09:21:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![SKumarMN](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skumarmn/32/27537_2.png) [@SKumarMN](https://discuss.elastic.co/u/SKumarMN)\
**Post date:** [June 17, 2016, 9:21am UTC](https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135/1 "2016-06-17T09:21:31Z")

</div>

I have logstash 2.3.3 on windows server 2008 R2. When i go try to excute any command getting into bin folder of logsatsh., I get "=1.0 was unexpected at this time" as the error

I have java 1.8\_0.92 set as java\_home

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 18, 2016, 1:36am UTC](https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135/2 "2016-06-18T01:36:58Z")

</div>

Please provide the command you are running and the exact output that includes this error.

---

<div class="post-metadata">

**Author:** ![SKumarMN](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skumarmn/32/27537_2.png) [@SKumarMN](https://discuss.elastic.co/u/SKumarMN)\
**Post date:** [June 20, 2016, 6:21am UTC](https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135/3 "2016-06-20T06:21:41Z")

</div>

Hi,

I was running the command bin\logstash-plugin list. The issue happened whenever i run any of the valid logstash command. Then when i looked further, the issue was due to settings in JAVA\_OPTS in my system env variable. Once I reset it, it worked fine. In logstash2.1.1, for the same issue the error was much more user friendly and helped to resolve it. Should I raise a bug to make the error more user friendly.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:51am UTC](https://discuss.elastic.co/t/logstash-2-3-3-on-windows-1-0-was-unexpected-at-this-time-error/53135/4 "2017-07-06T04:51:57Z")

</div>


