# Logstash 2.4 install not working

**URL:** https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468
**Category:** Logstash
**Created:** [September 25, 2016, 9:15pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468 "2016-09-25T21:15:07Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![ddjembi](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@ddjembi](https://discuss.elastic.co/u/ddjembi)
#### Post date: [September 25, 2016, 9:15pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/1 "2016-09-25T21:15:07Z")

</div>

Hi,  
Just install Logstash on mac following [install instruction] ([https://www.elastic.co/guide/en/logstash/current/installing-logstash.html#installing-binary](https://www.elastic.co/guide/en/logstash/current/installing-logstash.html#installing-binary)).

First example works fine (bin/logstash -e 'input { stdin { } } output { stdout {} }')  
[second one] ([https://www.elastic.co/guide/en/logstash/current/advanced-pipeline.html#advanced-pipeline](https://www.elastic.co/guide/en/logstash/current/advanced-pipeline.html#advanced-pipeline)) fails with the following error  
Pipeline aborted due to error {:exception=\>"ArgumentError", :backtrace=\>["/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.5/lib/logstash/inputs/file.rb:187:in `register'", "org/jruby/RubyArray.java:1613:in`each'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.5/lib/logstash/inputs/file.rb:185:in `register'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:330:in`start\_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:329:in`start\_inputs'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:180:in `start_workers'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:136:in`run'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:491:in `start\_pipeline'"], :level=\>:error}

Any idea why is not working as instructed ???

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [September 25, 2016, 9:44pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/2 "2016-09-25T21:44:21Z")

</div>

Can you show us the entire command you are calling, along with the shell and error?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [September 26, 2016, 6:17am UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/3 "2016-09-26T06:17:16Z")

</div>

By reading the stacktrace I'd say the problem is that the file path you've given in the file input is relative and not absolute.

The error message is horrible and a regression from Logstash 2.3. I've filed an issue to get this addressed.

> <https://github.com/elastic/logstash/issues/5969>

---

<div class="post-metadata">

### Author: ![ddjembi](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@ddjembi](https://discuss.elastic.co/u/ddjembi)
#### Post date: [September 26, 2016, 6:32pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/4 "2016-09-26T18:32:29Z")

</div>

Logstash works fine with the following config in the inital-pipeline.conf file.  
input {  
generator {  
lines =\> [  
"line 1",  
"line 2"  
]  
count =\> 3  
}  
}  
output { stdout { } }

With the following command:  
~/Documents/elk/logstash-2.4.0 $ bin/logstash -f initial-pipeline.conf

It gives the following results:  
Settings: Default pipeline workers: 4  
Pipeline main started  
2016-09-26T18:18:34.420Z Denis-iMac27.local line 1  
2016-09-26T18:18:34.431Z Denis-iMac27.local line 2  
2016-09-26T18:18:34.431Z Denis-iMac27.local line 1  
2016-09-26T18:18:34.432Z Denis-iMac27.local line 2  
2016-09-26T18:18:34.432Z Denis-iMac27.local line 1  
2016-09-26T18:18:34.433Z Denis-iMac27.local line 2  
Pipeline main has been shutdown  
stopping pipeline {:id=\>"main"}

Trying the following config in first-pipeline.conf file  
input {  
file {  
path =\> "NOTICES.TXT"  
start\_position =\> beginning  
ignore\_older =\> 0  
}  
}  
output { stdout { } }

With the following command:  
~/Documents/elk/logstash-2.4.0 $ bin/logstash -f first-pipeline.conf

It fails with the following shell errors:  
Settings: Default pipeline workers: 4  
Pipeline aborted due to error {:exception=\>"ArgumentError", :backtrace=\>["/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.5/lib/logstash/inputs/file.rb:187:in `register'", "org/jruby/RubyArray.java:1613:in`each'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.5/lib/logstash/inputs/file.rb:185:in `register'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:330:in`start\_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:329:in`start\_inputs'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:180:in `start_workers'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:136:in`run'", "/Users/Denis/Documents/elk/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:491:in `start\_pipeline'"], :level=\>:error}  
stopping pipeline {:id=\>"main"}.

Logstash also fails with all other config filters, inputs and output I've tried so far !!!

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [September 26, 2016, 6:59pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/5 "2016-09-26T18:59:08Z")

</div>

> ```
> path => "NOTICES.TXT"
> 
> ```

As I said, this path must not be relative.

---

<div class="post-metadata">

### Author: ![ddjembi](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@ddjembi](https://discuss.elastic.co/u/ddjembi)
#### Post date: [September 26, 2016, 7:21pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/6 "2016-09-26T19:21:56Z")

</div>

Unbelievable !!! But you're right, everything works fine when using absolute path...  
I cannot even begin to understand the poor quality of error message for such trivial error.

I'm just starting experiencing logstash and I've got some dozens of xml file to map into elastic. My hope was to use logstash and not a developing xml transformation myself to generate json files for import into elastic.

Is this kind of logstash error message a bug in 2.4 ... or should I expect any errors to be reported in such cryptic fashion ?

Thanks for your help anyway.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [September 26, 2016, 7:39pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/7 "2016-09-26T19:39:53Z")

</div>

> Is this kind of logstash error message a bug in 2.4 ... or should I expect any errors to be reported in such cryptic fashion ?

As I said, this is a bug that was introduced in Logstash 2.4.

---

<div class="post-metadata">

### Author: ![aghierna](https://avatars.discourse-cdn.com/v4/letter/a/85f322/32.png) [@aghierna](https://discuss.elastic.co/u/aghierna)
#### Post date: [September 29, 2016, 9:34am UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/8 "2016-09-29T09:34:55Z")

</div>

Hi there!  
It seems like I have a very similar problem. However, I have an absolute path and still get the same error.  
I copy my conf file and the error:  
input {  
file {  
path =\> "/Users/agarciah/Disco\_D/Consultoria/Lineas/lineas.csv"  
type =\> "lineas"  
start\_position =\> "beginning"  
}  
}

running: $ bin/logstash -f /users/agarciah/Downloads/logstashLineas.conf

gives:

Settings: Default pipeline workers: 4  
Pipeline aborted due to error {:exception=\>"ArgumentError", :backtrace=\>["/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.5/lib/logstash/inputs/file.rb:221:in `register'", "/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:330:in`start\_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:329:in`start\_inputs'", "/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:180:in `start_workers'", "/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:136:in`run'", "/usr/local/Cellar/logstash/2.4.0/libexec/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:491:in `start\_pipeline'"], :level=\>:error}  
stopping pipeline {:id=\>"main"}

Mac OSX - logstash 2.4 - elasticsearch 2.3.4

Thanks!

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [September 29, 2016, 3:49pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/9 "2016-09-29T15:49:34Z")

</div>

Logstash seems to be complaining about your `sincedb_path` setting:

> <https://github.com/logstash-plugins/logstash-input-file/blob/v2.2.5/lib/logstash/inputs/file.rb#L221>

---

<div class="post-metadata">

### Author: ![aghierna](https://avatars.discourse-cdn.com/v4/letter/a/85f322/32.png) [@aghierna](https://discuss.elastic.co/u/aghierna)
#### Post date: [September 29, 2016, 5:14pm UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/10 "2016-09-29T17:14:31Z")

</div>

Thanks for your support. I changed the sincedb\_path:  
input {  
file {  
path =\> "/Users/agarciah/Disco\_D/Consultoria/Lineas/lineas.csv"  
type =\> "lineas"  
start\_position =\> "beginning"  
sincedb\_path =\> "/Users/agarciah/Disco\_D/Consultoria/Lineas/sincedb.txt"  
}  
}  
I can see sincedb.txt after running logstash but the same error message appears.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 4:36am UTC](https://discuss.elastic.co/t/logstash-2-4-install-not-working/61468/11 "2017-07-06T04:36:24Z")

</div>


