# Logstash-5.0.0.deb not installing correctly on Raspbian 8

**URL:** <https://discuss.elastic.co/t/logstash-5-0-0-deb-not-installing-correctly-on-raspbian-8/65427>\
**Category:** Logstash\
**Created:** [November 9, 2016, 1:40am UTC](https://discuss.elastic.co/t/logstash-5-0-0-deb-not-installing-correctly-on-raspbian-8/65427 "2016-11-09T01:40:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![dom1](https://avatars.discourse-cdn.com/v4/letter/d/a3d4f5/32.png) [@dom1](https://discuss.elastic.co/u/dom1)\
**Post date:** [November 9, 2016, 1:40am UTC](https://discuss.elastic.co/t/logstash-5-0-0-deb-not-installing-correctly-on-raspbian-8/65427/1 "2016-11-09T01:40:05Z")

</div>

Hi,

I'm trying to get logstash installed on my Rpi. I got an error at installation and when running "sudo dpkg-reconfigure logstash". The error is the following :  
`Using provided startup.options file: /etc/logstash/startup.options Java HotSpot(TM) Client VM warning: TieredCompilation is disabled in this release. Sending all logs to /tmp/tmp.X4aZcY19iH /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.24/lib/pleaserun/installer.rb:46 warning: executable? does not in this environment and will return a dummy value Successfully created system startup script for Logstash`

Googling shows that pleaserun is related to init script creation and the installation is actually missing init.d startup script.

Is there a way to correct this problem ?

Regards,  
Dominique

Add 1: just to not that there is no /tmp/tmp.X4aZcY19iH file and the /var/log/dpkg.log does not contain information on the error.

---

<div class="post-metadata">

**Author:** ![dom1](https://avatars.discourse-cdn.com/v4/letter/d/a3d4f5/32.png) [@dom1](https://discuss.elastic.co/u/dom1)\
**Post date:** [November 9, 2016, 1:21pm UTC](https://discuss.elastic.co/t/logstash-5-0-0-deb-not-installing-correctly-on-raspbian-8/65427/2 "2016-11-09T13:21:50Z")

</div>

Hi,

Though the error/warning on dpkg-reconfigure, it seems that "/etc/systemd/system/logstash.service" is present and that I can 'sudo service logstash start'.

After corrected some errors in "/var/log/syslog" and "/var/log/logstash/logstash-plain.log", I get a '[2016-11-09T14:19:21,240][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}'

Sorry to post in the first place as this was not a problem.

Regards,  
Dom

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 7, 2016, 1:21pm UTC](https://discuss.elastic.co/t/logstash-5-0-0-deb-not-installing-correctly-on-raspbian-8/65427/3 "2016-12-07T13:21:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
