# Logstash 5.1.1 plugin install not working

**URL:** <https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200>\
**Category:** Logstash\
**Created:** [December 15, 2016, 5:05pm UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200 "2016-12-15T17:05:54Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![B200](https://avatars.discourse-cdn.com/v4/letter/b/eb8c5e/32.png) [@B200](https://discuss.elastic.co/u/B200)\
**Post date:** [December 15, 2016, 5:05pm UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200/1 "2016-12-15T17:05:54Z")

</div>

I am new to elastic and doing a PoC project for logstash , elastic search and kibana with JVM monitoring with JMX. I am trying to install logstash-input-jmx and getting the below error. I tried with another plugin logstash-input-log4j and getting the same error. I think something simple is missing in my setup and hence none of the plugin install is working.

my JVM is : 1.8.111  
logstash, elastic search and Kibana : 5.1.1

```
An error occurred while installing logstash-core-event-java (5.1.1), and Bundler cannot continue.
Make sure that `gem install logstash-core-event-java -v '5.1.1'` succeeds before bundling.
WARNING: SSLSocket#session= is not supported
Error Bundler::InstallError, retrying 10/10
An error occurred while installing logstash-core-event-java (5.1.1), and Bundler cannot continue.
Make sure that `gem install logstash-core-event-java -v '5.1.1'` succeeds before bundling.
WARNING: SSLSocket#session= is not supported
Too many retries, aborting, caused by Bundler::InstallError
ERROR: Installation Aborted, message: An error occurred while installing logstash-core-event-java (5.1.1),
 and Bundler cannot continue.
Make sure that `gem install logstash-core-event-java -v '5.1.1'` succeeds before bundling.
```

---

<div class="post-metadata">

**Author:** ![moe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moe/32/14258_2.png) [@moe](https://discuss.elastic.co/u/moe)\
**Post date:** [January 3, 2017, 3:43am UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200/2 "2017-01-03T03:43:41Z")

</div>

I'm running into the same issue with trying to install the salesforce plugin. My suspicion is this has something to do with a version issue surrounding jruby and bundler but I have not been able to make it work.

---

<div class="post-metadata">

**Author:** ![hellqvio](https://avatars.discourse-cdn.com/v4/letter/h/8491ac/32.png) [@hellqvio](https://discuss.elastic.co/u/hellqvio)\
**Post date:** [January 3, 2017, 1:11pm UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200/3 "2017-01-03T13:11:44Z")

</div>

I am also running into the same problem

---

<div class="post-metadata">

**Author:** ![sothawo](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sothawo](https://discuss.elastic.co/u/sothawo)\
**Post date:** [January 7, 2017, 5:24am UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200/4 "2017-01-07T05:24:20Z")

</div>

got the same problem with logstash-output-syslog

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 4, 2017, 5:24am UTC](https://discuss.elastic.co/t/logstash-5-1-1-plugin-install-not-working/69200/5 "2017-02-04T05:24:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
