# Logstash 5.6.0 not starting

**URL:** <https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241>\
**Category:** Logstash\
**Created:** [September 20, 2017, 9:51pm UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241 "2017-09-20T21:51:20Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![kamalbeg](https://avatars.discourse-cdn.com/v4/letter/k/aca169/32.png) [@kamalbeg](https://discuss.elastic.co/u/kamalbeg)\
**Post date:** [September 20, 2017, 9:51pm UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/1 "2017-09-20T21:51:20Z")

</div>

Hello,

I have 3 ES server running in cluster. I have x-pack install on all 3 ES, kibana and LS. They all are running ver 5.6.0

I am getting following error

[2017-09-20T17:45:14,760][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<Errno::EADDRNOTAVAIL: Cannot assign requested address - bind - Cannot assign requested address\>, :backtrace=\>["org/jruby/ext/socket/RubyTCPServer.java:118:in `initialize'", "org/jruby/RubyIO.java:871:in`new'", "/opt/elastic/logstash-5.6.0/vendor/bundle/jruby/1.9/gems/puma-2.16.0-java/lib/puma/binder.rb:234:in `add_tcp_listener'", "(eval):2:in`add\_tcp\_listener'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/webserver.rb:88:in `start_webserver'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/webserver.rb:44:in`run'", "org/jruby/RubyRange.java:476:in `each'", "org/jruby/RubyEnumerable.java:971:in`each\_with\_index'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/webserver.rb:39:in `run'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/agent.rb:222:in`start\_webserver'"]}

in my logstash.yml file, I have the following

http.host: "10.24.240.253"  
xpack.monitoring.enabled: true  
xpack.monitoring.elasticsearch.url: "[http://10.24.240.253:9200](http://10.24.240.253:9200)"  
xpack.monitoring.elasticsearch.username: "logstash\_internal"  
xpack.monitoring.elasticsearch.password: "k3yb4nkelk"

I am running LS on the on one of the 3 ES node.

my conf file is very simple

input {

stdin {}  
}

output {

stdout{}  
}

Any help will be appricaiated

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 20, 2017, 11:37pm UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/2 "2017-09-20T23:37:01Z")

</div>

> [@kamalbeg](#):
>
> http.host: "10.24.240.253"

What happens if you uncomment that?

---

<div class="post-metadata">

**Author:** ![kamalbeg](https://avatars.discourse-cdn.com/v4/letter/k/aca169/32.png) [@kamalbeg](https://discuss.elastic.co/u/kamalbeg)\
**Post date:** [September 20, 2017, 11:45pm UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/3 "2017-09-20T23:45:29Z")

</div>

It works in a sense that I do not get the FATAL error and I am getting the data in splunk but I see the following error now

[2017-09-20T19:44:49,742][ERROR][logstash.outputs.elasticsearch] Encountered an unexpected error submitting a bulk request! Will retry. {:error\_message=\>"undefined method `sanitized' for #<String:0x74f34347>", :class=>"NoMethodError", :backtrace=>["/opt/elastic/logstash-5.6.0/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:249:in`safe\_bulk'", "/opt/elastic/logstash-5.6.0/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:119:in `submit'", "/opt/elastic/logstash-5.6.0/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:87:in`retrying\_submit'", "/opt/elastic/logstash-5.6.0/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:38:in `multi_receive'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/output_delegator_strategies/shared.rb:13:in`multi\_receive'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/output\_delegator.rb:49:in `multi_receive'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/pipeline.rb:436:in`output\_batch'", "org/jruby/RubyHash.java:1342:in `each'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/pipeline.rb:435:in`output\_batch'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/pipeline.rb:381:in `worker_loop'", "/opt/elastic/logstash-5.6.0/logstash-core/lib/logstash/pipeline.rb:342:in`start\_workers'"]}

---

<div class="post-metadata">

**Author:** ![kamalbeg](https://avatars.discourse-cdn.com/v4/letter/k/aca169/32.png) [@kamalbeg](https://discuss.elastic.co/u/kamalbeg)\
**Post date:** [September 20, 2017, 11:45pm UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/4 "2017-09-20T23:45:46Z")

</div>

sorry I mean data in Elastic.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 21, 2017, 12:26am UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/5 "2017-09-21T00:26:32Z")

</div>

Check your Elasticsearch logs, it should tell you something more.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 19, 2017, 12:26am UTC](https://discuss.elastic.co/t/logstash-5-6-0-not-starting/101241/6 "2017-10-19T00:26:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
