# Logstash-5.6.2-1 logstash.service failed to load: No such file or directory

**URL:** https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172
**Category:** Logstash
**Created:** [September 28, 2017, 7:33pm UTC](https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172 "2017-09-28T19:33:29Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![scch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scch/32/25504_2.png) [@scch](https://discuss.elastic.co/u/scch)
#### Post date: [September 28, 2017, 7:33pm UTC](https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172/1 "2017-09-28T19:33:29Z")

</div>

Hi , I have installed Logstash-5.6.2-1 through yum repo.. on centOS 7.  
it installed successfully. however I am unable to start the service.

sudo systemctl start logstash. it gives following error.

Failed to start logstash.service: Unit logstash.service failed to load: No such file or directory.

request help suggestions..

---

<div class="post-metadata">

### Author: ![scch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scch/32/25504_2.png) [@scch](https://discuss.elastic.co/u/scch)
#### Post date: [September 29, 2017, 3:21am UTC](https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172/2 "2017-09-29T03:21:14Z")

</div>

can't see any file named 'Logstash.service' in path '/etc/systemd/system' can some one check and see if installation creates 'Logstash.service' file for you.

if yes, can some one share its configuration?

---

<div class="post-metadata">

### Author: ![scch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scch/32/25504_2.png) [@scch](https://discuss.elastic.co/u/scch)
#### Post date: [September 29, 2017, 6:40am UTC](https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172/3 "2017-09-29T06:40:43Z")

</div>

Resolved 🙂 \>\>\>the issue was with JAVA...  
JAVA\_HOME was pointing to user/JDK-1.8.0 because java was configured manually through .TAR file.  
& While installation logstash look for java in usr/bin/java.  
reinstalled java through yum and then logstash solved the problem.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 27, 2017, 6:40am UTC](https://discuss.elastic.co/t/logstash-5-6-2-1-logstash-service-failed-to-load-no-such-file-or-directory/102172/4 "2017-10-27T06:40:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
