# Logstash 5.6.8 output to es can't add workers error

**URL:** <https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562>\
**Category:** Logstash\
**Created:** [April 11, 2018, 2:55am UTC](https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562 "2018-04-11T02:55:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [April 11, 2018, 2:55am UTC](https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562/1 "2018-04-11T02:55:37Z")

</div>

when output to es i see the docs at [https://www.elastic.co/guide/en/logstash/5.6/plugins-outputs-elasticsearch.html#plugins-outputs-elasticsearch-workers](https://www.elastic.co/guide/en/logstash/5.6/plugins-outputs-elasticsearch.html#plugins-outputs-elasticsearch-workers)  
i see it can add the workers but when add the es is output error can't start

error is:  
`[2018-04-11T10:50:09,233][ERROR][logstash.agent] Cannot create pipeline {:reason=>"You are using a plugin that doesn't support workers but have set the workers value explicitly! This plugin uses the shared and doesn't need this option"}`

configure output file is:

```
 output {
  elasticsearch { 
  hosts => ["xx:9200","xx:9200","xx:9200","xx:9200","xx:9200"] 
  user => "xx" 
  password => "xx" 
  index => "xxx-data-%{+YYYY.MM.dd}" 
  document_type => "docs" 
  id => "toes"
  workers => 8
  }
 }

```

when setting workers logstash can't start.

---

<div class="post-metadata">

**Author:** ![Suman\_Reddy1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/suman_reddy1/32/27303_2.png) [@Suman\_Reddy1](https://discuss.elastic.co/u/Suman_Reddy1)\
**Post date:** [April 11, 2018, 3:33am UTC](https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562/2 "2018-04-11T03:33:29Z")

</div>

The error clearly says it doesnt support workers. Any how as the doc suggests its a string values. Try giving it in double quotes

---

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [April 11, 2018, 3:37am UTC](https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562/3 "2018-04-11T03:37:59Z")

</div>

add "" the error is also.  
thanks.  
you can test in you env logstash. it a bug?  
i see the default is 1 ,but the machine is have many cpus . this can't change so bad.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 9, 2018, 3:47am UTC](https://discuss.elastic.co/t/logstash-5-6-8-output-to-es-cant-add-workers-error/127562/4 "2018-05-09T03:47:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
