# Logstash 5 Alpha4 with Xpack getting error in log

**URL:** https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474
**Category:** Logstash
**Created:** [July 14, 2016, 6:16am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474 "2016-07-14T06:16:25Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![gaurav\_S\_javheri](https://avatars.discourse-cdn.com/v4/letter/g/82dd89/32.png) [@gaurav\_S\_javheri](https://discuss.elastic.co/u/gaurav_S_javheri)
#### Post date: [July 14, 2016, 6:16am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/1 "2016-07-14T06:16:25Z")

</div>

elasticsearch is secured with xpack security and hooked with ldap which is working fine. Even user has admin right in role\_mapping.

Below is configuration  
output {  
elasticsearch {  
hosts =\> ['localhost:9200']  
user =\> 'gaurav@gmail.com'  
password =\> 'pwd'  
}  
}

Getting below error and because of which logstash is starting up correctly.

{:timestamp=\>"2016-07-14T11:40:39.917000+0530", :message=\>"Pipeline aborted due to error", :exception=\>#\<URI::InvalidComponentError: bad component(expected userinfo component or user component): [gaurav@gmail.com](mailto:gaurav@gmail.com)\>, :backtrace=\>["/usr/share/logstash/vendor/jruby/lib/ruby/1.9/uri/generic.rb:412:in `check_user'", "/usr/share/logstash/vendor/jruby/lib/ruby/1.9/uri/generic.rb:483:in`user='", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:242:in `normalize_url'", "org/jruby/RubyArray.java:2414:in`map'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:253:in `update_urls'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:66:in`initialize'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:135:in `build_pool'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http_client.rb:20:in`initialize'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/http\_client\_builder.rb:52:in `build'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch.rb:159:in`build\_client'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:13:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:86:in`register'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:184:in `start_workers'", "org/jruby/RubyArray.java:1613:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:184:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:139:in`run'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:240:in `start\_pipeline'"], :level=\>:error, :file=\>"logstash/agent.rb", :line=\>"242", :method=\>"start\_pipeline"}

Please help me to solve below problem

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 14, 2016, 10:01am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/2 "2016-07-14T10:01:57Z")

</div>

At a guess, it doesn't like the `@` in the username.  
Can you try with a user name that doesn't have this?

---

<div class="post-metadata">

### Author: ![gaurav\_S\_javheri](https://avatars.discourse-cdn.com/v4/letter/g/82dd89/32.png) [@gaurav\_S\_javheri](https://discuss.elastic.co/u/gaurav_S_javheri)
#### Post date: [July 14, 2016, 11:06am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/3 "2016-07-14T11:06:41Z")

</div>

You are right. Thanks a lot for quick suggestion .

Now I can see below exception

{:timestamp=\>"2016-07-14T16:32:29.592000+0530", :message=\>"Encountered an unexpected error submitting a bulk request! Will retry.", :error\_message=\>"undefined method `code' for #<LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError:0x97f8a30>", :class=>"NoMethodError", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:217:in`safe\_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:105:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:72:in`retrying\_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:23:in `multi_receive'", "org/jruby/RubyArray.java:1653:in`each\_slice'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:22:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:136:in`threadsafe\_multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegator.rb:122:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:321:in`output\_batch'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:321:in`output\_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:249:in `worker_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:210:in`start\_workers'"], :level=\>:error, :file=\>"logstash/outputs/elasticsearch/common.rb", :line=\>"78", :method=\>"retrying\_submit"}

and I can see no data is passed to elasticsearch. Please provide your suggestion.

---

<div class="post-metadata">

### Author: ![gaurav\_S\_javheri](https://avatars.discourse-cdn.com/v4/letter/g/82dd89/32.png) [@gaurav\_S\_javheri](https://discuss.elastic.co/u/gaurav_S_javheri)
#### Post date: [July 19, 2016, 12:33pm UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/4 "2016-07-19T12:33:59Z")

</div>

@warkolm . do you have any more suggestion on above issue?

---

<div class="post-metadata">

### Author: ![eebf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eebf/32/11105_2.png) [@eebf](https://discuss.elastic.co/u/eebf)
#### Post date: [July 28, 2016, 3:11pm UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/5 "2016-07-28T15:11:53Z")

</div>

I am having the same issue here using Logstah 5 and an output plugin to Elasticsearch. Here is the error I am having:

> {:timestamp=\>"2016-07-28T14:56:08.854000+0000", :message=\>"Encountered an unexpected error submitting a bulk request! Will retry.", :error\_message=\>"undefined method `code' for #<LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError:0xb1765fd>", :class=>"NoMethodError", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:217:in `safe\_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:182:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:105:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:72:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:23:in `multi\_receive'", "org/jruby/RubyArray.java:1653:in `each_slice'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-4.1.1-java/lib/logstash/outputs/elasticsearch/common.rb:22:in `multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegator.rb:136:in `threadsafe_multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:122:in `multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:321:in `output_batch'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:321:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:249:in `worker\_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:210:in `start\_workers'"], :level=\>:error}

And here is the configuration I am using in the Logstash server:

output {

> ```
> elasticsearch {
> hosts => ["elasticsearch-server:443"]
> codec => "json"
> 
> ```

> ```
> ssl => true
> 
> ```

> ```
> ssl_certificate_verification => true
> }
> 
> ```

If you guys have any idea about that it will be great!

Thank you very much!

---

<div class="post-metadata">

### Author: ![eebf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eebf/32/11105_2.png) [@eebf](https://discuss.elastic.co/u/eebf)
#### Post date: [July 28, 2016, 5:16pm UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/6 "2016-07-28T17:16:20Z")

</div>

After looking around I saw that there is an issue with the current version of the elasticsearch output plugin. After updating it I saw that the message now changes:

> {:timestamp=\>"2016-07-28T17:13:24.193000+0000", :message=\>"Got a bad response code from server, but this code is not considered retryable. Request will be dropped", :code=\>403, :level=\>:error}

Seems like there was a bug in the previous version which was preventing the system to output the correct message.

---

<div class="post-metadata">

### Author: ![da\_Teng](https://avatars.discourse-cdn.com/v4/letter/d/a183cd/32.png) [@da\_Teng](https://discuss.elastic.co/u/da_Teng)
#### Post date: [August 25, 2016, 2:26am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/7 "2016-08-25T02:26:22Z")

</div>

Have you reslove this 403 error？How？

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 4:41am UTC](https://discuss.elastic.co/t/logstash-5-alpha4-with-xpack-getting-error-in-log/55474/8 "2017-07-06T04:41:42Z")

</div>


