# Logstash 5 alpha5-1 - Failed to load settings file from "path.settings". Aborting

**URL:** <https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360>\
**Category:** Logstash\
**Created:** [August 18, 2016, 2:25pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360 "2016-08-18T14:25:23Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 18, 2016, 2:25pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/1 "2016-08-18T14:25:23Z")

</div>

I'm getting the following error when try run:

```
# /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/logstash.conf
--- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.0
--- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.1-1
Logstash has a new settings file which defines start up time settings. This file is typically located in $LS_HOME/config or /etc/logstash. If you installed Logstash through a package and are starting it manually please specify the location to this settings file by passing in "--path.settings=/path/.." in the command line options {:level=>:warn}

Failed to load settings file from "path.settings". Aborting... {"path.settings"=>"/usr/share/logstash/config", "exception"=>Errno::ENOENT, "message"=>"No such file or directory - /usr/share/logstash/config/logstash.yml", :level=>:fatal}

```

JAVA  
#java -version  
openjdk version "1.8.0\_101"

Logstash version

```
#yum list installed | grep logstash
logstash.noarch 1:5.0.0~alpha5-1 @logstash-5.0

```

Plugin beats

```
# /usr/share/logstash/bin/logstash-plugin list | grep beat
logstash-input-beats

```

Logstash conf

```
# cat /etc/logstash/conf.d/logstash.conf
input {
  beats {
    port => 5044
  }
}

output {
  elasticsearch {
    hosts => "localhost:9200"
    manage_template => false
    index => "%{[@metadata][beat]}-%{+YYYY.MM.dd}"
    document_type => "%{[@metadata][type]}"
  }
}

```

I'm using CentOS 7.

```
#cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)

```

Someone can help?

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 18, 2016, 2:53pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/2 "2016-08-18T14:53:05Z")

</div>

The error message you pasted explains what went wrong and how to fix it. I'll re-paste what you have above and add line breaks to make it easier to read without scrolling left to right (I'm not trying to be patronizing. I'm trying to make it easier for future readers to see the issue and understand the fix):

```nohighlight
Logstash has a new settings file which defines start up time settings. 

This file is typically located in $LS_HOME/config or /etc/logstash. 

If you installed Logstash through a package and are starting it manually 

please specify the location to this settings file by passing in 

"--path.settings=/path/.." in the command line options {:level=>:warn}

Failed to load settings file from "path.settings". 

Aborting... {"path.settings"=>"/usr/share/logstash/config", 
"exception"=>Errno::ENOENT, 
"message"=>"No such file or directory - /usr/share/logstash/config/logstash.yml", 
:level=>:fatal}

```

What this means is that you should start Logstash with a manually configured `--path.settings`, like this:

Before:

```nohighlight
# /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/logstash.conf

```

After:

```nohighlight
# /usr/share/logstash/bin/logstash --path.settings /etc/logstash -f /etc/logstash/conf.d/logstash.conf

```

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 18, 2016, 5:05pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/3 "2016-08-18T17:05:03Z")

</div>

Ok, Really work! Thanks!

But, can i do for the logstash work normally, when i run with "service logstash start"?

My instalation was done with yum, using the following repo:

```
[logstash-5.0]
name=Logstash repository for 5.0.x packages
baseurl=https://packages.elastic.co/logstash/5.0/centos
gpgcheck=1
gpgkey=https://packages.elastic.co/GPG-KEY-elasticsearch
enabled=1

```

I haved put the **path.settings** configuration in "/etc/logstash/logstash.yml" and tried run "service logstash start" but dont work.

My /etc/logstash/logstash.yml:

```
path.data: /usr/share/logstash
path.config: /etc/logstash/conf.d
path.log: /var/log/logstash/logstash.log
path.settings: /etc/logstash

```

Other thing, the port is up under IPV6.

> '# netstat -ntl | grep 5044  
> tcp6 0 0 :::5044 :::\* list

Do you know where i can configure for IPV4?

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 18, 2016, 5:21pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/4 "2016-08-18T17:21:14Z")

</div>

> [@rwagner](#):
>
> I haved put the path.settings configuration in "/etc/logstash/logstash.yml" and tried run "service logstash start" but dont work.

What version of RHEL/CentOS are you using? That may determine how Logstash needs to be started.

Did you edit `/etc/logstash/logstash.yml`? You shouldn't have needed to change the `path.settings` attribute as it was preconfigured to point there already.

> [@rwagner](#):
>
> Do you know where i can configure for IPV4?

```auto
input {
  beats {
    host => "127.0.0.1"
    port => 5044
  }
}

```

That should do IPv4.

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 18, 2016, 5:47pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/5 "2016-08-18T17:47:33Z")

</div>

> [@theuntergeek](#):
>
> What version of RHEL/CentOS are you using? That may determine how Logstash needs to be started.
> 
> > [@rwagner](#):
> >
> > I'm using CentOS 7.
> > 
> > #cat /etc/redhat-release  
> > CentOS Linux release 7.2.1511 (Core)
> 
> Did you edit /etc/logstash/logstash.yml? You shouldn't have needed to change the path.settings attribute as it was preconfigured to point there already.

Yes, i haved put the path.settings attribute after you say to run with this attribute, i try put in the logstash.yml configurations file, thinking it would work, but no.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 18, 2016, 7:20pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/6 "2016-08-18T19:20:35Z")

</div>

> [@rwagner](#):
>
> I'm using CentOS 7.

That's why it isn't working. You're using upstart syntax and CentOS 7 is systemctl. Logstash 5 is auto-detecting the system init type and creating startup files accordingly. It just so happens that systemctl supersedes upstart, so it's the default on RHEL/CentOS 7.

See [https://www.elastic.co/guide/en/logstash/5.0/running-logstash.html:](https://www.elastic.co/guide/en/logstash/5.0/running-logstash.html:)

> `sudo systemctl start logstash.service`

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 19, 2016, 1:24pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/7 "2016-08-19T13:24:36Z")

</div>

> [@theuntergeek](#):
>
> sudo systemctl start logstash.service

Hi Aaron,

In this way logstash really runs, but apparently he ignores the configuration file in the `/etc/logstash/conf.d/logstash.conf` , because the configured port for the beats don't up.

If i run in this way `/usr/share/logstash/bin/logstash --path.settings /etc/logstash -f /etc/logstash/conf.d/logstash.conf`, the port up.

The configuration is:

> [@rwagner](#):
>
> ´# cat /etc/logstash/conf.d/logstash.conf  
> input {  
> beats {  
> port =\> 5044  
> }  
> }
> 
> output {  
> elasticsearch {  
> hosts =\> "localhost:9200"  
> manage\_template =\> false  
> index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
> document\_type =\> "%{[@metadata][type]}"  
> }  
> }

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 19, 2016, 2:40pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/8 "2016-08-19T14:40:48Z")

</div>

Without some `-v` verbose logs (or possibly debug logs), I won't be able to know what's going on. You edited the default files, so I can't say for sure whether that caused it or not. It _should_ have picked up anything ending in `.conf` in `/etc/logstash/conf.d`. This is being used by many people everywhere right now, so I'm keen to know why it's not working for you.

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 19, 2016, 4:42pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/9 "2016-08-19T16:42:34Z")

</div>

> [@theuntergeek](#):
>
> Without some -v verbose logs (or possibly debug logs), I won't be able to know what's going on. You edited the default files, so I can't say for sure whether that caused it or not. It should have picked up anything ending in .conf in /etc/logstash/conf.d. This is being used by many people everywhere right now, so I'm keen to know why it's not working for you.

I tried install all again. I haved install the CentOS vm again and the logstash from aforementioned yum repo, and the problem continues.

Below, the logstash running in two ways that I said:

Executed by systemctl

 ![](https://us1.discourse-cdn.com/elastic/original/2X/a/a04f3cdf9661b1cef92d36448bf8b6a7755a7467.png)

Executed by command:

 ![](https://us1.discourse-cdn.com/elastic/original/2X/b/bd152923bbf7aaaef6f0f4ccf6e878b1aa5f4009.png)

I only have one `.conf` file in the `/etc/logstash/conf.d`.  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/0/06b1cf2120f8b6c264b416691bbe01889bc96b40.png)

The `-v` option don't work in logstash. If you want reproduce, you can install CentOS (install java by `yum`) and install the `logstash alpha5` by the yum repo.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 19, 2016, 5:38pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/10 "2016-08-19T17:38:17Z")

</div>

I don't know what's going on in your box, but a freshly spun up vagrant with CentOS 7 yields this:

```auto
[vagrant@localhost logstash]$ cat /etc/logstash/logstash.yml | grep -v ^#
path.data: /var/lib/logstash
path.config: /etc/logstash/conf.d
path.log: /var/log/logstash/logstash.log

```

```auto
[vagrant@localhost logstash]$ cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)

```

```auto
[vagrant@localhost logstash]$ yum list installed | grep logstash
logstash.noarch 1:5.0.0~alpha5-1 @logstash-5.0

```

```auto
[vagrant@localhost logstash]$ cat /etc/logstash/conf.d/logstash.conf
input {
  beats {
    port => 5044
  }
}

output {
  stdout { codec => rubydebug }
}

```

```auto
[vagrant@localhost logstash]$ netstat -ntl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp6 0 0 :::5044 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 ::1:25 :::* LISTEN
tcp6 0 0 127.0.0.1:9600 :::* LISTEN

```

```auto
[vagrant@localhost logstash]$ systemctl status logstash
● logstash.service - logstash
   Loaded: loaded (/etc/systemd/system/logstash.service; disabled; vendor preset: disabled)
   Active: active (running) since Fri 2016-08-19 17:31:57 UTC; 4min 1s ago
 Main PID: 30241 (java)
   CGroup: /system.slice/logstash.service
           └─30241 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Xm...

Aug 19 17:31:57 localhost.localdomain systemd[1]: Started logstash.
Aug 19 17:31:57 localhost.localdomain systemd[1]: Starting logstash...
Aug 19 17:32:23 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.0
Aug 19 17:32:23 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.1-1
Aug 19 17:32:28 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.core:jackson-core already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 17:32:28 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 17:32:28 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 17:32:28 localhost.localdomain logstash[30241]: --- jar coordinate com.fasterxml.jackson.module:jackson-module-afterburner already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 17:32:29 localhost.localdomain logstash[30241]: ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.
Aug 19 17:32:31 localhost.localdomain logstash[30241]: {:timestamp=>"2016-08-19T17:32:31.468000+0000", :message=>"Pipeline main started"}

```

As you can see, the only thing I've changed is the Logstash output (no elasticsearch, just stdout). I get the correct port running for Beats.

Again, I don't know what's going on inside your box, but I can't reproduce your problem locally ☹

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 19, 2016, 6:29pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/11 "2016-08-19T18:29:19Z")

</div>

> [@theuntergeek](#):
>
> As you can see, the only thing I've changed is the Logstash output (no elasticsearch, just stdout). I get the correct port running for Beats.
> 
> Again, I don't know what's going on inside your box, but I can't reproduce your problem locally

Hey Aaron, i think which the problem is something with permission. I saw that you were running with a non root user, and i intall all whith root. Then i restored a snapshot from the VM and add a new user(non root) and install all using `sudo`(e.g `sudo yum intall logstash`), thus it functioned.

If you can try install all with a root user, i think which you can reproduce.

But, for now, it's work.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 19, 2016, 6:45pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/12 "2016-08-19T18:45:59Z")

</div>

The commands needed with root or sudo were anything yum, e.g. `sudo yum install logstash`, and systemctl, e.g. `sudo systemctl start logstash`. And of course, to edit the config file. I just used sudo, nothing special.

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 19, 2016, 7:05pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/13 "2016-08-19T19:05:29Z")

</div>

> [@theuntergeek](#):
>
> The commands needed with root or sudo were anything yum, e.g. sudo yum install logstash, and systemctl, e.g. sudo systemctl start logstash. And of course, to edit the config file. I just used sudo, nothing special.

So, i understood what you said! What I said was that, when i installed, there was only the root user on the host. In this way it was installed, runned and edited all with the root user.

I believe that in this way you can reproduce, instaling and running all with root user, without using sudo(e.g `# yum install logstash` or `# systemctl start logstash`).

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 19, 2016, 7:39pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/14 "2016-08-19T19:39:03Z")

</div>

That shouldn't matter. To leave no stone unturned, I tried what you described. It still worked for me, however, it took longer to finish launching:

```auto
[root@localhost logstash]# systemctl status logstash
● logstash.service - logstash
   Loaded: loaded (/etc/systemd/system/logstash.service; disabled; vendor preset: disabled)
   Active: active (running) since Fri 2016-08-19 19:21:14 UTC; 4min 10s ago
 Main PID: 30861 (java)
   CGroup: /system.slice/logstash.service
           └─30861 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Xm...

Aug 19 19:21:14 localhost.localdomain systemd[1]: Started logstash.
Aug 19 19:21:14 localhost.localdomain systemd[1]: Starting logstash...
Aug 19 19:21:39 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.0
Aug 19 19:21:39 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.1-1
Aug 19 19:22:19 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.core:jackson-core already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 19:22:19 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 19:22:19 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 19:22:19 localhost.localdomain logstash[30861]: --- jar coordinate com.fasterxml.jackson.module:jackson-module-afterburner already loaded with version 2.7.1 - omit version 2.7.5
Aug 19 19:22:20 localhost.localdomain logstash[30861]: ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.
Aug 19 19:22:21 localhost.localdomain logstash[30861]: {:timestamp=>"2016-08-19T19:22:21.254000+0000", :message=>"Pipeline main started"}

```

```auto
[root@localhost logstash]# netstat -ntl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp6 0 0 :::5044 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 ::1:25 :::* LISTEN
tcp6 0 0 127.0.0.1:9600 :::* LISTEN

```

When launched via sudo (see my earlier post), it took 26 seconds after launch before the jar messages start, and then another 8 seconds before `Pipeline main started`. When launched as root, it took 25 seconds after launch before the jar messages start, and then an additional _42_ seconds before `Pipeline main started`.

I do not think this has anything to do with Logstash, as Logstash has already been started _as the Logstash user,_ and both implementations seem to have reached the jar loading section at the same time, so permissions have already been set. I could be wrong, but I do not know what could be done by Logstash differently. It's not like there's a flag somewhere that detected the user which started _the systemctl process_ that _spawned_ the Logstash process.

---

<div class="post-metadata">

**Author:** ![rwagner](https://avatars.discourse-cdn.com/v4/letter/r/d9b06d/32.png) [@rwagner](https://discuss.elastic.co/u/rwagner)\
**Post date:** [August 21, 2016, 1:05pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/15 "2016-08-21T13:05:30Z")

</div>

Well Aaron, I do not know what happened, but happened. 😁  
Sorry about not reproduce the situation.

Anyway, sorry for whatever and thanks for the help!

And the following configuration don't work for the IPV6 problem: [quote="theuntergeek, post:4, topic:58360"]  
host =\> "127.0.0.1"  
[/quote]

What worked for me was, i have put the following configuration in the `/etc/sysctl.conf` file:

```
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

```

Again, thank you for being so solicitous!

---

<div class="post-metadata">

**Author:** ![andySFt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andysft/32/16476_2.png) [@andySFt](https://discuss.elastic.co/u/andySFt)\
**Post date:** [March 19, 2017, 7:50pm UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/16 "2017-03-19T19:50:44Z")

</div>

Have you find out what the problem was?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:27am UTC](https://discuss.elastic.co/t/logstash-5-alpha5-1-failed-to-load-settings-file-from-path-settings-aborting/58360/17 "2017-07-06T04:27:44Z")

</div>


