# Logstash 5 error to start with configuration

**URL:** <https://discuss.elastic.co/t/logstash-5-error-to-start-with-configuration/55210>\
**Category:** Logstash\
**Created:** [July 11, 2016, 3:40pm UTC](https://discuss.elastic.co/t/logstash-5-error-to-start-with-configuration/55210 "2016-07-11T15:40:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![dhy3ives](https://avatars.discourse-cdn.com/v4/letter/d/e9a140/32.png) [@dhy3ives](https://discuss.elastic.co/u/dhy3ives)\
**Post date:** [July 11, 2016, 3:40pm UTC](https://discuss.elastic.co/t/logstash-5-error-to-start-with-configuration/55210/1 "2016-07-11T15:40:09Z")

</div>

Hi  
I'm using logstash 5 - zip file version, and trying run a conf, but receive this erros bellow.

My start config  
[elk@elk bin]$ ./logstash -f beats-syslog.conf -r -l /opt/elk/logs/logstash-syslog-apache.log --log.level info

```
Logstash has a new settings file which defines start up time settings. This file is typically located in $LS_HOME/config or /etc/logstash. If you installed Logstash through a package and are starting it manually please specify the location to this settings file by passing in "--path.settings=/path/.." in the command line options {:level=>:warn}
Failed to load settings file from "path.settings". Aborting... {"path.settings"=>"/opt/elk/logstash-5/config", "exception"=>Psych::SyntaxError, "message"=>"(<unknown>): expected <block end>, but found BlockMappingStart while parsing a block mapping at line 79 column 2", :level=>:fatal}

```

Some can help me about this error?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 13, 2016, 4:06am UTC](https://discuss.elastic.co/t/logstash-5-error-to-start-with-configuration/55210/2 "2016-07-13T04:06:16Z")

</div>

If you read the error it tells you what to do.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:48am UTC](https://discuss.elastic.co/t/logstash-5-error-to-start-with-configuration/55210/3 "2017-07-06T04:48:24Z")

</div>


