# Logstash 5 not running

**URL:** https://discuss.elastic.co/t/logstash-5-not-running/64449
**Category:** Logstash
**Created:** [October 31, 2016, 1:20pm UTC](https://discuss.elastic.co/t/logstash-5-not-running/64449 "2016-10-31T13:20:40Z")
**Posts on this page:** 1
**Showing post:** 70

<div class="post-metadata">

### Author: ![georgezoto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/georgezoto/32/18855_2.png) [@georgezoto](https://discuss.elastic.co/u/georgezoto)
#### Post date: [January 10, 2018, 5:28pm UTC](https://discuss.elastic.co/t/logstash-5-not-running/64449/70 "2018-01-10T17:28:18Z")

</div>

Look also at this topic:

> [@Logstash requires setting a file](https://discuss.elastic.co/t/logstash-requires-setting-a-file/64658):
>
> Logstash Info error: A setting file is missing I installed the deb file of logstash 5.0 and I starting logstash for the first time. I get an INFO error: INFO: Logstash requires a setting file which is typically located in $LS\_HOME/config or /etc/logstash. If you installed Logstash through a package and are starting it manually please specify the location to this settings file by passing in "--path.settings=/path/.." ERROR: Failed to load settings file from "path.settings". Aborting... path.s…

and issues resolved:

> <https://github.com/elastic/logstash/issues/6164>
>
> Logstash installed via rpm and apt packages cannot be manually started with \`-e\`… flag. \`-e\` flag's behavior is to merge config string supplied via command line to config file supplied via \`-f\`. Now, in packages, \`logstash.yml\` is implicitly setting \`path.config\` to \`/etc/logstash/conf.d/\*\`. This means whenever a user does 
> 
> \`\`\`
> bin/logstash -e 'foo'
> \`\`\`
> 
> it is actually merging contents of directory \`/etc/logstash.conf.d\` 
> 
> For a fresh installation, no config files are found and LS bails with an error.
> 
> A combination of all these issues causes a lot of confusion for first users and users experienced with pre-5.0 behavior where there was no \`logstash.yml\`
> 
> Related: https://github.com/elastic/logstash/issues/6062
> https://discuss.elastic.co/t/logstash-5-not-running/64449
> 
> Also, our documentation for getting started instructs to use \`e\`, so this is needs to be fixed.

> <https://github.com/elastic/logstash/pull/6165>
>
> Previously if both -e and -f was specified, LS required that
> \-f still have vali…d config file(s) before merging. This fixes it
> to either have one of -f or -e provided
> 
> Fixes #6164

---

_[View the full topic](https://discuss.elastic.co/t/logstash-5-not-running/64449)._
