# Logstash 5.x to 7.x - Gzip Files

**URL:** <https://discuss.elastic.co/t/logstash-5-x-to-7-x-gzip-files/209718>\
**Category:** Logstash\
**Created:** [November 27, 2019, 3:42pm UTC](https://discuss.elastic.co/t/logstash-5-x-to-7-x-gzip-files/209718 "2019-11-27T15:42:11Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![MaikLinnemann](https://avatars.discourse-cdn.com/v4/letter/m/8c91f0/32.png) [@MaikLinnemann](https://discuss.elastic.co/u/MaikLinnemann)\
**Post date:** [November 27, 2019, 3:42pm UTC](https://discuss.elastic.co/t/logstash-5-x-to-7-x-gzip-files/209718/1 "2019-11-27T15:42:11Z")

</div>

Hi,

is there a change in file input for logstash 7.x? I struggle about an issue with reading gzip files. in my old version 5.x i could give like:

input {  
file {  
path =\> "/var/log/packetfilter.\*"  
}  
}

And it reads all files including gzip files.

In 7.x i get errors about charset:

"Received an event that has a different character encoding than you configured"

I solved it with:

input {  
file {  
path =\> "/var/log/packetfilter._"  
exclude =\> "_.gz"  
codec =\> plain { charset =\> "ASCII" }  
}  
}

So far no more errors but sadly not reading gzip.

I found it nice to be able to read gzip as well if i need to. How can i archive the old way and read gzip as well on a demand?

Thanks and Regards,

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 25, 2019, 3:54pm UTC](https://discuss.elastic.co/t/logstash-5-x-to-7-x-gzip-files/209718/2 "2019-12-25T15:54:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
