# Logstash 6.2.3 Failed to create monitoring event

**URL:** https://discuss.elastic.co/t/logstash-6-2-3-failed-to-create-monitoring-event/130464
**Category:** Logstash
**Created:** [May 3, 2018, 1:54pm UTC](https://discuss.elastic.co/t/logstash-6-2-3-failed-to-create-monitoring-event/130464 "2018-05-03T13:54:10Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![roketyyang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roketyyang/32/8783_2.png) [@roketyyang](https://discuss.elastic.co/u/roketyyang)
#### Post date: [May 3, 2018, 1:54pm UTC](https://discuss.elastic.co/t/logstash-6-2-3-failed-to-create-monitoring-event/130464/1 "2018-05-03T13:54:10Z")

</div>

I can't get any help from similar topics.

```auto
[2018-05-03T21:45:28,088][ERROR][logstash.inputs.metrics] Failed to create monitoring event {:message=>"For path: events. Map keys: [:pipelines, :reloads]", :error=>"LogStash::Instrument::MetricStore::MetricNotFound"}

```

I have one logstash works fine, but when I start second logstash(the `config/logstash.yml` is same, unless `node.name` and `xpack.management.pipeline.id`), always suffer the ERROR above.

Any help is appreciate!

---

<div class="post-metadata">

### Author: ![roketyyang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roketyyang/32/8783_2.png) [@roketyyang](https://discuss.elastic.co/u/roketyyang)
#### Post date: [May 3, 2018, 2:55pm UTC](https://discuss.elastic.co/t/logstash-6-2-3-failed-to-create-monitoring-event/130464/4 "2018-05-03T14:55:52Z")

</div>

I fund the problem, Your pipeline.id cannot start correctly will cause `Failed to create monitoring event`.  
Such as

```auto
Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:apm-metric, :exception=>"LogStash::ConfigurationError"

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 31, 2018, 2:55pm UTC](https://discuss.elastic.co/t/logstash-6-2-3-failed-to-create-monitoring-event/130464/5 "2018-05-31T14:55:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
