# Logstash 6.5.2 does not start with openjdk11

**URL:** https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334
**Category:** Logstash
**Created:** [December 11, 2018, 9:35am UTC](https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334 "2018-12-11T09:35:48Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)
#### Post date: [December 11, 2018, 9:35am UTC](https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334/1 "2018-12-11T09:35:49Z")

</div>

Hello,

Since it was announced that ELK stack has support of Java 11 since 6.5.0 release I thought that I could start it on openjdk11. When starting I can see in the logs the following error:

```
Dec 10 17:18:28 mgt-wazuh-02 logstash[26570]: Unrecognized VM option 'UseParNewGC'
Dec 10 17:18:28 mgt-wazuh-02 logstash[26570]: Error: Could not create the Java Virtual Machine.
Dec 10 17:18:28 mgt-wazuh-02 logstash[26570]: Error: A fatal exception has occurred. Program will exit.

```

Any way I can make it happen? Note elasticsearch started up without any issues

---

<div class="post-metadata">

### Author: ![balumurari1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/balumurari1/32/39203_2.png) [@balumurari1](https://discuss.elastic.co/u/balumurari1)
#### Post date: [December 14, 2018, 5:47am UTC](https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334/2 "2018-12-14T05:47:17Z")

</div>

As per my knowledge,right now, ELK doesnt support for jdk11. It is good to use jdk8/10.

> [@Logstash and Java 11](https://discuss.elastic.co/t/logstash-and-java-11/159570/2):
>
> We are working on adding support for Java 11. There is a meta issue with more details: [https://github.com/elastic/logstash/issues/9345](https://github.com/elastic/logstash/issues/9345).

---

<div class="post-metadata">

### Author: ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)
#### Post date: [December 18, 2018, 12:57pm UTC](https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334/3 "2018-12-18T12:57:06Z")

</div>

I was looking at the 6.5.0 annoucement where they posted support for java 11 for elasticsearch therefore I assumed that logstash is also suporting Java 11 since in lots of the cases elasticsearch would be sharing hosts with logstash therefore they would both need to run on the same java installation.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 15, 2019, 12:57pm UTC](https://discuss.elastic.co/t/logstash-6-5-2-does-not-start-with-openjdk11/160334/4 "2019-01-15T12:57:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
