# Logstash 6.6.2 java execution | AIX

**URL:** <https://discuss.elastic.co/t/logstash-6-6-2-java-execution-aix/177953>\
**Category:** Logstash\
**Created:** [April 23, 2019, 6:32am UTC](https://discuss.elastic.co/t/logstash-6-6-2-java-execution-aix/177953 "2019-04-23T06:32:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sl1729](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sl1729](https://discuss.elastic.co/u/sl1729)\
**Post date:** [April 23, 2019, 6:32am UTC](https://discuss.elastic.co/t/logstash-6-6-2-java-execution-aix/177953/1 "2019-04-23T06:32:18Z")

</div>

Hello Team,

We have setup a ELK cluster in RHEL based machine but we have some apps running in AIX machine where I am trying to setup logstash 6.6.2 to monitor those.

But when i try to bring up logstash it starts and crash with this below error,

`[ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (NotImplementedError) block device detection unsupported or native support failed to load; see http://wiki.jruby.org/Native-Libraries`

Java version : 1.8

And my conf file is very simple one

```
input {
  file {
    path => "/tmp/test.log"
    mode => "tail"
  }
}

output {
  elasticsearch {
    hosts => "elastic-host.intra"
    user => "elastic"
    password => "changeme"
    ssl => false
    index => "testindex"
  }
}
```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [April 23, 2019, 8:32am UTC](https://discuss.elastic.co/t/logstash-6-6-2-java-execution-aix/177953/2 "2019-04-23T08:32:26Z")

</div>

As per the [support matrix](https://www.elastic.co/support/matrix#matrix_jvm) AIX is not a supported platform and IBM Java is not a supported JVM.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2019, 8:42am UTC](https://discuss.elastic.co/t/logstash-6-6-2-java-execution-aix/177953/3 "2019-05-21T08:42:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
