# Logstash 6.6.2 unable to read postfix maillog and there is no error in the log

**URL:** <https://discuss.elastic.co/t/logstash-6-6-2-unable-to-read-postfix-maillog-and-there-is-no-error-in-the-log/173666>\
**Category:** Logstash\
**Created:** [March 25, 2019, 4:08am UTC](https://discuss.elastic.co/t/logstash-6-6-2-unable-to-read-postfix-maillog-and-there-is-no-error-in-the-log/173666 "2019-03-25T04:08:11Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![subramani\_ponnuswamy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subramani_ponnuswamy/32/42651_2.png) [@subramani\_ponnuswamy](https://discuss.elastic.co/u/subramani_ponnuswamy)\
**Post date:** [March 25, 2019, 4:08am UTC](https://discuss.elastic.co/t/logstash-6-6-2-unable-to-read-postfix-maillog-and-there-is-no-error-in-the-log/173666/1 "2019-03-25T04:08:11Z")

</div>

I have configured the logstash.conf file and run there is no error found. but it does'nt read the log file. Kindly help to fix this.

logstash.config file details below:

input {  
file {  
type =\> "postfix"  
path =\> "d:\maillog\maillog"  
exclude =\> "\*.gz"  
start\_position =\> "beginning"  
}  
}  
filter {  
if [type] == "postfix" {  
grok {  
patterns\_dir =\> ["c:\logstash\config\patterns"]  
match =\> { "message" =\> ["%{PF}", "%{DOVECOT}"] }  
}  
date {  
match =\> ["timestamp", "MMM dd HH:mm:ss"]  
}  
}

# I wanted to monitor metrics and health of logstash

metrics {  
meter =\> "events"  
add\_tag =\> "metric"  
}  
}  
output {  
stdout {

```
}

```

}

---

<div class="post-metadata">

**Author:** ![subramani\_ponnuswamy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subramani_ponnuswamy/32/42651_2.png) [@subramani\_ponnuswamy](https://discuss.elastic.co/u/subramani_ponnuswamy)\
**Post date:** [March 25, 2019, 8:11am UTC](https://discuss.elastic.co/t/logstash-6-6-2-unable-to-read-postfix-maillog-and-there-is-no-error-in-the-log/173666/2 "2019-03-25T08:11:53Z")

</div>

The issue got resolved after changing the file path parameter (c:/_/_).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 22, 2019, 8:11am UTC](https://discuss.elastic.co/t/logstash-6-6-2-unable-to-read-postfix-maillog-and-there-is-no-error-in-the-log/173666/3 "2019-04-22T08:11:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
