# Logstash 7.1.0 problem on Install

**URL:** <https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522>\
**Category:** Logstash\
**Created:** [May 23, 2019, 9:33pm UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522 "2019-05-23T21:33:44Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![kingram](https://avatars.discourse-cdn.com/v4/letter/k/ecb155/32.png) [@kingram](https://discuss.elastic.co/u/kingram)\
**Post date:** [May 23, 2019, 9:33pm UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522/1 "2019-05-23T21:33:44Z")

</div>

Hardware: Raspbberry Pi3 (arm processor)  
OS: Raspbian (Debian Stretch 9)  
Java: openjdk 10

```
$ bin/logstash -e 'input { stdin {} } output { stdout {} }'
OpenJDK Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/home/xxxxxxx/logstash-7.1.0/logstash-core/lib/jars/jruby-complete-9.2.7.0.jar) to field java.io.FileDescriptor.fd
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

```

What's going on here? How do I fix this error?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [May 23, 2019, 9:46pm UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522/2 "2019-05-23T21:46:43Z")

</div>

openjdk 10 is not [supported](https://www.elastic.co/support/matrix#matrix_jvm). Try using Java 8.

---

<div class="post-metadata">

**Author:** ![kingram](https://avatars.discourse-cdn.com/v4/letter/k/ecb155/32.png) [@kingram](https://discuss.elastic.co/u/kingram)\
**Post date:** [May 23, 2019, 10:07pm UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522/3 "2019-05-23T22:07:37Z")

</div>

Or probably forward to 11, because I installed 10 for Elasticsearch.  
The link to the support matrix was helpful though.

Going backward to openjdk 8 resolved the error, which suggests that it is a problem with jruby more than anything else.

Still didn't fix the problem though:

ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: ffi/ffi -- java.lang.NullPointerException: null

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [May 24, 2019, 12:04am UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522/4 "2019-05-24T00:04:37Z")

</div>

I cannot speak to why Java 10/11 might not work. I just know that other folks have posted about the "illegal reflective access" error and downgrading to Java 8 worked for them.

I know nothing about the "load error: ffi/ffi" error but I would note that a search for that in this forum finds a couple of occurrences, both on a Raspberry Pi.

And a search for Raspberry in this forum gives a set of results that does not look promising.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 21, 2019, 12:04am UTC](https://discuss.elastic.co/t/logstash-7-1-0-problem-on-install/182522/5 "2019-06-21T00:04:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
