# Logstash(7.1.1) is not working in windows 2012 R2 server

**URL:** <https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869>\
**Category:** Logstash\
**Created:** [June 27, 2019, 2:26pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869 "2019-06-27T14:26:23Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![jagadish\_panda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jagadish_panda/32/48925_2.png) [@jagadish\_panda](https://discuss.elastic.co/u/jagadish_panda)\
**Post date:** [June 27, 2019, 2:26pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/1 "2019-06-27T14:26:23Z")

</div>

Hi Team,

I am unable to start logstatsh 7.1.1, it got aborted and it does not create the log file. I am getting the below error message -  
warning: ignoring JAVA\_OPTS= -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitia  
tingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=  
true -Dfile.encoding=UTF-8 -Djruby.compile.invokedynamic=true -Djruby.jit.thresh  
old=0 -XX:+HeapDumpOnOutOfMemoryError -Djava.security.egd=file:/dev/urandom ; pa  
ss JVM parameters via LS\_JAVA\_OPTS

Kindly help.  
Regards,  
Jagadish

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 27, 2019, 2:38pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/2 "2019-06-27T14:38:25Z")

</div>

That is a warning that should not prevent logstash starting. Can you show the complete log file?

---

<div class="post-metadata">

**Author:** ![jagadish\_panda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jagadish_panda/32/48925_2.png) [@jagadish\_panda](https://discuss.elastic.co/u/jagadish_panda)\
**Post date:** [June 27, 2019, 2:39pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/3 "2019-06-27T14:39:27Z")

</div>

The log is not created.

---

<div class="post-metadata">

**Author:** ![jagadish\_panda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jagadish_panda/32/48925_2.png) [@jagadish\_panda](https://discuss.elastic.co/u/jagadish_panda)\
**Post date:** [June 27, 2019, 2:43pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/4 "2019-06-27T14:43:34Z")

</div>

Even I have tried in windows 7, it is working fine but in windows 2012 server, logstash got crashed, even log file also not get created in the folder. I have run the simple command to chcek my logstash is working fine or not -

logstash.bat -e "input { stdin { } } output { stdout {} }"

---

<div class="post-metadata">

**Author:** ![jagadish\_panda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jagadish_panda/32/48925_2.png) [@jagadish\_panda](https://discuss.elastic.co/u/jagadish_panda)\
**Post date:** [July 1, 2019, 12:21pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/5 "2019-07-01T12:21:56Z")

</div>

Could you please help me the above issue. Thanks in advance.

---

<div class="post-metadata">

**Author:** ![jagadish\_panda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jagadish_panda/32/48925_2.png) [@jagadish\_panda](https://discuss.elastic.co/u/jagadish_panda)\
**Post date:** [July 1, 2019, 1:19pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/6 "2019-07-01T13:19:22Z")

</div>

Even I typed logstash - h, I am getting the same error, Did I missed something?

Thanks.

D:\ELK\logstash-7.1.1\bin\>logstash -h  
warning: ignoring JAVA\_OPTS= -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitia  
tingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=  
true -Dfile.encoding=UTF-8 -Djruby.compile.invokedynamic=true -Djruby.jit.thresh  
old=0 -XX:+HeapDumpOnOutOfMemoryError -Djava.security.egd=file:/dev/urandom ; pa  
ss JVM parameters via LS\_JAVA\_OPTS

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2019, 1:19pm UTC](https://discuss.elastic.co/t/logstash-7-1-1-is-not-working-in-windows-2012-r2-server/187869/7 "2019-07-29T13:19:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
