# Logstash 7.16.2(fixed Log4j2 Vulnerability) connected to ElasticSearch 7.6.2 failed

**URL:** <https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945>\
**Category:** Logstash\
**Created:** [December 27, 2021, 2:39am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945 "2021-12-27T02:39:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![swxEmily](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/swxemily/32/99555_2.png) [@swxEmily](https://discuss.elastic.co/u/swxEmily)\
**Post date:** [December 27, 2021, 2:39am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945/1 "2021-12-27T02:39:29Z")

</div>

Third party Elasticsearch: 7.6.2  
Logstash: updated from 7.10.1 to 7.16.2(fixed Log4j2 Vulnerability)

logstash.conf:  
output {  
Elasticsearch{  
hosts =\> ["[https://10.33.27.xxx:9200](https://10.33.27.xxx:9200)","[https://10.33.27.xxy:9200](https://10.33.27.xxy:9200)","[https://10.33.27.xxz:9200](https://10.33.27.xxz:9200)"]  
user =\> "admin"  
password =\> "xxxxx"  
cacert =\> "xxxxx"  
ilm\_enabled =\> false  
index =\> "xxxx-%{+YYYY.MM.dd}"  
manage\_template =\> true  
template\_overwrite =\> true  
template\_name =\> "xxxx\_template"  
}  
}

It works fine when logstash version is 7.10.1  
After upgrade to 7.16.2, get the error:

[2021-12-27T09:44:20,042][ERROR][logstash.javapipeline][main] Pipeline error {:pipeline\_id=\>"main", :exception=\>#\<LogStash::ConfigurationError: Could not connect to a compatible version of Elasticsearch\>, :backtrace=\>["/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/outputs/Elasticsearch/http\_client/pool.rb:247:in `block in healthcheck!'", "org/jruby/RubyHash.java:1415:in `each'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/outputs/Elasticsearch/http\_client/pool.rb:240:in `healthcheck!'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.2.3-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:374:in `update\_urls'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/outputs/Elasticsearch/http\_client/pool.rb:89:in `update_initial_urls'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.2.3-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:83:in `start'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/outputs/Elasticsearch/http\_client.rb:359:in `build_pool'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.2.3-java/lib/logstash/outputs/elasticsearch/http_client.rb:63:in `initialize'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/outputs/Elasticsearch/http\_client\_builder.rb:106:in `create_http_client'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.2.3-java/lib/logstash/outputs/elasticsearch/http_client_builder.rb:102:in `build'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-Elasticsearch-11.2.3-java/lib/logstash/plugin\_mixins/Elasticsearch/common.rb:34:in `build_client'", "/home/test/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.2.3-java/lib/logstash/outputs/elasticsearch.rb:275:in `register'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:131:in `register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:68:in `register'", "/home/test/logstash/logstash-core/lib/logstash/java\_pipeline.rb:232:in `block in register_plugins'", "org/jruby/RubyArray.java:1821:in `each'", "/home/test/logstash/logstash-core/lib/logstash/java\_pipeline.rb:231:in `register_plugins'", "/home/test/logstash/logstash-core/lib/logstash/java_pipeline.rb:589:in `maybe\_setup\_out\_plugins'", "/home/test/logstash/logstash-core/lib/logstash/java\_pipeline.rb:244:in `start_workers'", "/home/test/logstash/logstash-core/lib/logstash/java_pipeline.rb:189:in `run'", "/home/test/logstash/logstash-core/lib/logstash/java\_pipeline.rb:141:in `block in start'"], "pipeline.sources"=\>["/home/test/conf/logstash.conf"], :thread=\>"#\<Thread:0x3a3c3828 run\>"}  
[2021-12-27T09:44:20,053][INFO][logstash.javapipeline][main] Pipeline terminated {"pipeline.id"=\>"main"}  
[2021-12-27T09:44:20,078][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2021-12-27T09:44:20,188][INFO][logstash.runner] Logstash shut down.  
[2021-12-27T09:44:20,201][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]  
at home.test.logstash.lib.bootstrap.environment.(/home/test/logstash/lib/bootstrap/environment.rb:94) ~[?:?]

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [December 27, 2021, 2:55am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945/2 "2021-12-27T02:55:25Z")

</div>

That might be [this](https://discuss.elastic.co/t/logstash-not-start-after-upgrade-to-new-version/291849) issue. With 7.15 OSS stopped being a drop-in replacement for Elastic.

---

<div class="post-metadata">

**Author:** ![swxEmily](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/swxemily/32/99555_2.png) [@swxEmily](https://discuss.elastic.co/u/swxEmily)\
**Post date:** [December 27, 2021, 4:22am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945/3 "2021-12-27T04:22:51Z")

</div>

> **[Opensearch 1.2.3](https://opensearch.org/downloads.html)**
>
> OpenSearch is a community-driven, open source search and analytics suite derived from Apache 2.0 licensed Elasticsearch 7.10.2 & Kibana 7.10.2. It consists of a search engine daemon, OpenSearch, and a visualization and user interface, OpenSearch...

---

<div class="post-metadata">

**Author:** ![swxEmily](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/swxemily/32/99555_2.png) [@swxEmily](https://discuss.elastic.co/u/swxEmily)\
**Post date:** [December 27, 2021, 4:24am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945/4 "2021-12-27T04:24:16Z")

</div>

download logstash-oss-with-opensearch-output-plugin-7.16.2-linux-x64.tar.gz from [Opensearch 1.2.3 · OpenSearch](https://opensearch.org/downloads.html)  
change the logstash.conf:  
output {  
opensearch{  
hosts =\> ["[https://10.33.27.xxx:9200](https://10.33.27.xxx:9200/)","[https://10.33.27.xxy:9200](https://10.33.27.xxy:9200/)","[https://10.33.27.xxz:9200](https://10.33.27.xxz:9200/)"]  
user =\> "admin"  
password =\> "xxxxx"  
cacert =\> "xxxxx"  
index =\> "xxxx-%{+YYYY.MM.dd}"  
manage\_template =\> true  
template\_overwrite =\> true  
template\_name =\> "xxxx\_template"  
}  
}

now it works fine.  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 24, 2022, 4:24am UTC](https://discuss.elastic.co/t/logstash-7-16-2-fixed-log4j2-vulnerability-connected-to-elasticsearch-7-6-2-failed/292945/5 "2022-01-24T04:24:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
