# Logstash 7.2.0 install error

**URL:** <https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356>\
**Category:** Logstash\
**Created:** [July 1, 2019, 3:26pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356 "2019-07-01T15:26:33Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [July 1, 2019, 3:26pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/1 "2019-07-01T15:26:33Z")

</div>

I was upgrading whole stack to 7.2.0 and got following error

Updating / installing...  
1:logstash-1:7.2.0-1 ################################# [17%]  
Using provided startup.options file: /etc/logstash/startup.options  
Unrecognized VM option 'UseParNewGC'  
Error: Could not create the Java Virtual Machine.  
Error: A fatal exception has occurred. Program will exit.  
Unable to install system startup script for Logstash.

but rpm -qa says it is installed

# rpm -qa |grep logsta

logstash-7.2.0-1.noarch

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [July 1, 2019, 3:42pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/2 "2019-07-01T15:42:25Z")

</div>

Getting following error in logstash for all jdbc

Failed to load /usr/lib/oracle/12.2/client64/lib/ojdbc8.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [July 1, 2019, 3:53pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/3 "2019-07-01T15:53:49Z")

</div>

> [@elasticforme](#):
>
> Failed to load /usr/lib/oracle/12.2/client64/lib/ojdbc8.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader

That is a known [issue](https://github.com/logstash-plugins/logstash-filter-jdbc_static/issues/47#issuecomment-496606449). Read down to the end of the thread for additional issues.

The unrecognized VM option error suggests you are using a JRE that is [not supported](https://www.elastic.co/support/matrix#matrix_jvm).

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [July 1, 2019, 4:07pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/4 "2019-07-01T16:07:57Z")

</div>

OK fixed it.  
just incase putting it here incase someone came across same

in logstash conf dir, jvm.options file do this  
#-XX:+UseParNewGC ------\> comment this  
#-XX:+UseConcMarkSweepGC ------\> comment this  
-XX:+UseG1GC ----\> Add this line

copy your original jar file to logstash jar dir. or you can create a link there.

`# cp /usr/lib/oracle/12.2/client64/lib/ojdbc8.jar /usr/share/logstash/logstash-core/lib/jars/`

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [July 1, 2019, 4:15pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/5 "2019-07-01T16:15:15Z")

</div>

> [@Badger](#):
>
> That is a known [issue](https://github.com/logstash-plugins/logstash-filter-jdbc_static/issues/47#issuecomment-496606449). Read down to the end of the thread for additional issues.
> 
> The unrecognized VM option error suggests you are using a JRE that is [not supported](https://www.elastic.co/support/matrix#matrix_jvm).

@Badger, I just upgraded java and elk stack

# java -version

java version "12.0.1" 2019-04-16  
Java(TM) SE Runtime Environment (build 12.0.1+12)  
Java HotSpot(TM) 64-Bit Server VM (build 12.0.1+12, mixed mode, sharing)

Do you think I got wrong java? But this was only problem with jdbc and everything else is working fine

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [July 1, 2019, 5:21pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/6 "2019-07-01T17:21:06Z")

</div>

Java 12 is not supported. That does not necessarily mean anything will fail.

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [July 1, 2019, 6:26pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/7 "2019-07-01T18:26:31Z")

</div>

ok. I guess will keep that java until it fails and  
use jdbc8 in to /usr/share/logstash/logstash-core/lib/jars dir to keep this going

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2019, 6:26pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/8 "2019-07-29T18:26:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

---

<div class="post-metadata">

**Author:** ![Adam\_Fink](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adam_fink/32/45742_2.png) [@Adam\_Fink](https://discuss.elastic.co/u/Adam_Fink)\
**Post date:** [January 29, 2021, 11:33pm UTC](https://discuss.elastic.co/t/logstash-7-2-0-install-error/188356/9 "2021-01-29T23:33:41Z")

</div>

solved my issue. Thank you for sharing!
