# Logstash 7.9.1-1 installation errors - service not found

**URL:** <https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644>\
**Category:** Logstash\
**Created:** [September 5, 2020, 5:09pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644 "2020-09-05T17:09:35Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)\
**Post date:** [September 5, 2020, 5:09pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/1 "2020-09-05T17:09:35Z")

</div>

Hi there,  
Just tried re-installing logstash having removed it on an ubuntu server and had the following errors:

```auto
Get:1 https://artifacts.elastic.co/packages/7.x/apt stable/main amd64 logstash all 1:7.9.1-1 [159 MB]
Fetched 159 MB in 35s (4,555 kB/s)
Selecting previously unselected package logstash.
(Reading database ... 198511 files and directories currently installed.)
Preparing to unpack .../logstash_1%3a7.9.1-1_all.deb ...
Unpacking logstash (1:7.9.1-1) ...
Setting up logstash (1:7.9.1-1) ...
sed: can't read /etc/logstash/logstash.yml: No such file or directory
/etc/logstash/startup.options is not a file path
To manually specify a startup style, put the path to startup.options as the
first argument, followed by the startup style (sysv, upstart, systemd)
chmod: cannot access '/etc/logstash/startup.options': No such file or directory

```

Then when trying to start logstash, the service is not found.  
Is this due to me manually removng things after removing it?

If so, how can I repair or fix things?  
What's the best way to get back to a completly vanilla install?

Many thanks.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [September 5, 2020, 5:39pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/2 "2020-09-05T17:39:04Z")

</div>

Does /etc/logstash exist and who owns it?

---

<div class="post-metadata">

**Author:** ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)\
**Post date:** [September 5, 2020, 5:41pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/3 "2020-09-05T17:41:51Z")

</div>

Yes - it does. Owned by root.  
The /etc/logstash directory has a logstash.yml file and a conf.d directory present, and nothing more.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [September 5, 2020, 5:47pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/4 "2020-09-05T17:47:58Z")

</div>

> [@finbarr996](#):
>
> The /etc/logstash directory has a logstash.yml file

and yet it logs

```
can't read /etc/logstash/logstash.yml: No such file or directory

```

You are running the install as root, right?

---

<div class="post-metadata">

**Author:** ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)\
**Post date:** [September 5, 2020, 5:50pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/5 "2020-09-05T17:50:56Z")

</div>

Yes - correct.  
I'm wondering if the problem exists because I removed a previous install with apt.

There seem to be various artefacts remaining which relate to the previous installation - I'd like to nuke everything and get back to a clean install of logstash if I can.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [September 5, 2020, 5:52pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/6 "2020-09-05T17:52:27Z")

</div>

I would be tempted to run the install with 'strace -f -o /tmp/trace.txt ...' and see what errors it is getting when accessing those files under /etc/logstash.

---

<div class="post-metadata">

**Author:** ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)\
**Post date:** [September 5, 2020, 5:54pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/7 "2020-09-05T17:54:05Z")

</div>

Okay - will do.  
I have to head out now - but i'll try this first thing tomorrow - thank you for your help!

---

<div class="post-metadata">

**Author:** ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)\
**Post date:** [September 6, 2020, 12:40pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/8 "2020-09-06T12:40:14Z")

</div>

In the end, I felt the server was no longer in a stable and reliable state, so I have rebuilt it and everything is working correctly again.

Thank you for taking the time to look at this and sorry I'm not able to give more insight in to what happened or why.

Kind regards,  
John.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 4, 2020, 12:40pm UTC](https://discuss.elastic.co/t/logstash-7-9-1-1-installation-errors-service-not-found/247644/9 "2020-10-04T12:40:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
